Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problems with osComm 2.2


John Pitts

Recommended Posts

Hello,

 

I have recently taken over my sisters website from the previous individual. I am by far not a web designer, however I have enough background to fumble my way through most things. I have moved it over to the new host, transfered the domain, and setup the sql database. The website is up, howver I am having issues with the image uploads... i have set the images to chmod 777 for testing and am able to upload one photo, however when it goes to auto generate the 3 other images (which I belive is the "Additional Image Thumbnail Utility", it gives me errors and fails to create the other images.

 

This is the error I get:

 

Error returned from alterimage class: 1 error.gif Thumb file: ../images/products/gear/IMG_0353s.jpg could not be created. error.gif Error returned from alterimage class: 1 error.gif Products Info file: ../images/products/gear/IMG_0353m.jpg could not be created. error.gif Error returned from alterimage class: 1

 

 

Can someone help?

Link to comment
Share on other sites

Do you really need 777 permissions? You should start with 755 (directories/folders) and 644 (files) and only change to 775/664 if osC reports that it can't write (777/666 as a desperate last resort, but be sure to change back to 755/644 when you're done uploading pictures, as "world writable" directories are a severe security hazard). Note that some hosts have installed security software (e.g., suPHP) that blocks access to "world writable" directories or files. It's possible that's what happened to you.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...