Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem with jquery file


surrfman

Recommended Posts

Is jquery-1.4.2.min.js a required file, as I can't see it in my back-up files of the orignal store; close I can get is the One Page Checkout add-on files, where the 1.4.2 shows up as a file to modify?, I did install OPC, but removed, or thought I removed the entire OPC files, including the sql statements, reverting back to pre-OPC files (including a 1.4.2) I had archived; changed to the new "Simple Checkout" by Jetta. There are call-outs for the file in the admin and store side template_top.php files. I took both call-outs out of both files, no luck there! Every since the OPC install, you cannot get past the dancing ajax loader to continue with checkout. I assume 1.4.2 is the root of the log-in problem, but not sure. Tried an archived version, no change.

 

Added a chunk of code to the checkout.php which gives the reason for error message using FireFox:

 

Error:null[Exception..."Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)" nsresult: "0x80004005

(NS_ERROR_FAILURE)" location: "JS frame::https://www.discountegauges.com/ext/jquery/jquery-1.4.2.min.js::

<TOP_LEVEL>:: line 130" data: no]

 

Does the message make any sense to any one?

 

I also thought of changing out the 1.4.2 file with one from the jquery site; I see they have newer versions of 1.4.2 and 1.4.3 ,but are afraid to try.

 

Thanks for any help I can get,

 

Timmy C

Link to comment
Share on other sites

The jQuery files are required in osCommerce 2.3 and later versions, but not with the older 2.2 series. Some Addons for osC 2.2x also added jQuery, so it depends on what you have added to your store.

 

It's safe to keep an older version of jQuery if it works for you. If you want to upgrade to the latest version (and you are running osC 2.3.1) you also need to update the jQueryUI file and any themes that you have.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...