Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

how to display specials price


justinswa

Recommended Posts

Hello,

 

OSC 2.2Rc2a

 

I can set up specials discounts in admin and the reduced price shows in red with the original price scored out when you look you look at the product details in product_info.php. Great. However, if you look at the product summary anywhere else - within its category or withing the specials category, only the original and not the reduced price shows. Anybody with any ideas how I can display the special price here as well?

 

Thanks

Link to comment
Share on other sites

I think it is only you as my RC2a store shows the reduced prices with the original scored out in every location that the products price appears, tables specials screen etc

 

Sorry but I have no answer to your problem

 

Martin

Live shop Phoenix 1.0.8.4 on PHP 7.4 Working my way up the versions.

Link to comment
Share on other sites

I think it is only you as my RC2a store shows the reduced prices with the original scored out in every location that the products price appears, tables specials screen etc

 

Sorry but I have no answer to your problem

 

Martin

 

Thank you for confirming my suspicions. I have a feeling that this may have gone wrong when I changed everything to make the site php 5.3 compatible. Just have to try and find out why which will be a bit more complicated.....

Link to comment
Share on other sites

Your problem could be here in

 

catalog/includes/functions/general.php

 

Find


$product_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . "
where products_id = '" . (int)$product_id . "' and status");

 

Replace with

 

$product_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . "
where products_id = '" . (int)$product_id . "' and status = 1");

 

This is listed in the update document as a Bug

 

Martin

Live shop Phoenix 1.0.8.4 on PHP 7.4 Working my way up the versions.

Link to comment
Share on other sites

Your problem could be here in

 

catalog/includes/functions/general.php

 

Find


$product_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . "
where products_id = '" . (int)$product_id . "' and status");

 

Replace with

 

$product_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . "
where products_id = '" . (int)$product_id . "' and status = 1");

 

This is listed in the update document as a Bug

 

Martin

 

Thanks, that was worth a try but didn't work. Could you tell me where you saw the bug reported please?

Link to comment
Share on other sites

Martin, thanks for your help. Have now resolved this. I had an addon that caused the problem. There are so many addons and hacks to this installation that there's hardly any original code left. I always try and annotate my hack so I can remind myself what I have done but the addons are not always well commented...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...