Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Product not found! error with attributes?


Guest

Recommended Posts

Hello,

Thanks in advance for any help you can provide! I've searched the forum, but I couldn't find anything relevant.

On my site, when you select a product that shares an attribute with a different product, and click add to cart, you get "Product not found!" Yet, the product is added, correctly, to the shopping cart.

 

As an example, In my attributes section of the admin area, I have:

Products: t shit and pants

Product Option: Size

Option Values: small, medium and large.

Product attributes(1): t-shirt, size, small, +5.00

Product attributes(2): pants, size, small, +10.00

 

Is the error cause by the fact that I amusing the same attribute for 2 different products and giving it a different value? How can I use the same attributes and values on different products?

 

Here is a link to one of my products: Blueberry plant Please click on add to cart, you'll see that it gets added, but the main screen says it can not find the product.

 

I hope I've given enough information. THANKS!!

 

John

Link to comment
Share on other sites

I just noticed that there are two different web addresses associated with one product. Depending on how you get to the product, on website, determines if the attributes will work. From the home page, if you click on a products that is listed as new for Feb., it brings you to this page: http://heritageorchards.com/root/catalog/product_info.php?products_id=85 AND the attributes work!

If you click on categories -> trees -> Persimmons -> Tanenashi, then the page link is http://heritageorchards.com/root/catalog/product_info.php?cPath=28_35&products_id=85 AND the attributes do not work!

 

Does that help? I have a very basic understanding of web design...Sorry!

 

John

Link to comment
Share on other sites

  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...