Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Recover Cart Sales for OSC 2.3.1


Mort-lemur

Recommended Posts

Taken the RCS for 2.2 and altered to work with 2.3.1 - All credit to the original authors.

 

Attempted to simplify installation instructions.

 

Download here: http://addons.oscommerce.com/info/8333

 

Enjoy.

Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Link to comment
Share on other sites

well done, it was on my neverending list to do.

 

However the install instructions are very far out of date.

 

Step 5:

Edit /catalog/admin/includes/application_top.php and add:

 

define('FILENAME_RECOVER_CART_SALES', 'recover_cart_sales.php');

define('FILENAME_STATS_RECOVER_CART_SALES', 'stats_recover_cart_sales.php');

define('TABLE_SCART', 'scart');

define('FILENAME_CATALOG_PRODUCT_INFO', 'product_info.php');

define('FILENAME_CATALOG_LOGIN', 'login.php');

 

 

Mark

Link to comment
Share on other sites

Thanks Mark,

 

I didnt say it was perfect or upto 2.3.1 standards - but hey it works.

 

Im thrashong through updating the addons that I need for my 2.3.1 development site as I cant wait for someone else to do them for me.

 

Please feel free to update to more "modern" standards

 

Thanks

Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Link to comment
Share on other sites

Taken the RCS for 2.2 and altered to work with 2.3.1 - All credit to the original authors.

 

Attempted to simplify installation instructions.

 

Download here: http://addons.oscommerce.com/info/8333

 

Enjoy.

 

I am certianly glad that you are taking the time to alter these add ons to work with 2.3.1 and actually releasing them as an add on. So many people say they have them working, but never release them. Thanks again it is appreciated.

REMEMBER BACKUP, BACKUP AND BACKUP

Link to comment
Share on other sites

Thanks Steve,

 

Releasing them as a contribution is also the best way I can think of of recording what I actually did - and giving those more experienced than me the opportunity to improve / tidy them.

 

Many Thanks

Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Link to comment
Share on other sites

  • 4 weeks later...

I love this contribution - thank you!

 

Running the tool to find abandoned carts works perfect. However, I can't find what I missed in the installation to cause my recovered sales report to have unfinished headings etc. See attached image.

 

Thanks in advance.

 

John

post-290684-0-91806200-1330700970_thumb.png

Link to comment
Share on other sites

You have not copied the admin/includes/languages/english/recover_cart_sales.php to the right place or at all.

 

Thanks

Now running on a fully modded, Mobile Friendly 2.3.4 Store with the Excellent MTS installed - See my profile for the mods installed ..... So much thanks for all the help given along the way by forum members.

Link to comment
Share on other sites

  • 2 months later...

I love this contribution - thank you!

 

Running the tool to find abandoned carts works perfect. However, I can't find what I missed in the installation to cause my recovered sales report to have unfinished headings etc. See attached image.

 

Thanks in advance.

 

John

 

I know this was posted a long time ago, but i had the same problem. It would appear that there is a languages file missing from the install. I copied the file stats_recover_cart_sales.php from an earlier version, and now the page does not have the missing defines.

REMEMBER BACKUP, BACKUP AND BACKUP

Link to comment
Share on other sites

  • 2 weeks later...

The idea of this contribution is great, but it doesn't send the emails. I have tried several times to send one to my own test account and still nothing. I have added the missing language file and the changes Mark listed, but I still don't get the email. I have to assume that the customers I tried to send one to have not received theirs either. I saw this mentioned somewhere with the old version, but now I can't find the post. Does anyone know what the problem could be?

Link to comment
Share on other sites

The idea of this contribution is great, but it doesn't send the emails. I have tried several times to send one to my own test account and still nothing. I have added the missing language file and the changes Mark listed, but I still don't get the email. I have to assume that the customers I tried to send one to have not received theirs either. I saw this mentioned somewhere with the old version, but now I can't find the post. Does anyone know what the problem could be?

 

I seem to have jumped the gun a little; I found the emails in Hotmail's infernal junk folder. But, there is an issue:

 

At the bottom it has the store name, then my name as a link to the site, under that is the store URL. I checked the raw source and my name is within the link tag. Is there some way to fix this? And will it show up as my name or the customer's name on others?

 

Also, I would like the PS to actually say PS by defualt, but I didn't see anywhere in the code or language file to put this in.

Link to comment
Share on other sites

  • 1 month later...

Hi, I too am having the problem of emails not being sent and also the problem of the report not having proper headings. Having looked through this thread and double checked one (not so obvious) omission is the lack of 'stats_recover_cart_sales.php' file within the admin/includes/classes folder (RS Steve mentions he used an older one but I'm not sure where to find it!)

 

Any help with the emails not sending would be appreciated.

 

Iain

Link to comment
Share on other sites

  • 2 weeks later...

OK, got the report 'Recovered Cart Sales' sorted by uploading this file https://www.box.com/s/883733b5ccab9631411f to /admin/includes/languages/english/ (file found from original 2.2 addon)

 

However, still nothing happens when I click the 'send email' within the tools section. My other addons which send emails (fancier invoices for example) work fine so I don't think it's an email config problem.

 

Any help in getting it to work or learning how to debug would be appreciated.

 

Iain

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...