Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

The requested URL was not found on this server


Guest

Recommended Posts

I know this has been covered a thousand times before but none of the previous solutions I have found seem to work in this case.

 

All of a sudden today I got the following PHP error;

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I thought I had fixed this by installing VGER's patch which got the site back up and running. However now my links don't work and I get (for example) the following;

 

The requested URL /tigers-gypsy-jimmy-piersall-p-8753.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Any ideas?

 

Cheers,

Mark.

Link to comment
Share on other sites

I suggest you download 2.3.1 and use the upgrade document included to get your cart up to speed.

Link to comment
Share on other sites

Hello Nick,

 

Thanks for the advice. I will certainly look into this. In the meantime do you know of a short term fix just so I can get the site back up and running?

 

Cheers,

Mark.

Link to comment
Share on other sites

Hello Chris,

 

I've read some of yours and Nick's posts on previous threads where you recommend just installing 2.3.1 rather than trying to upgrade from 2.2-MS2 and having to upgrade contributions etc. I understand I will lose all the contributions I have installed which I can probably just about live with but I will need to transfer my database (7500 products!!). From what I have read on here that isn't so straightforward. Any advice?

 

Thanks again,

Mark.

Link to comment
Share on other sites

@@punkrockcds.com,

 

Mark,

 

You can't use the 'import' option in PHPMYADMIN, however, you can integrate your products into the new database by opening the SQL dump from the old site with a text editor, copy the product DATA and then past it into the SQL tab of PHPMYADMIN. You will need to copy the data from all of the products tables to complete the integration. It is a little more time consuming but not that difficult.

 

 

 

Chris

Link to comment
Share on other sites

Been looking into this some more and it looks like I have 2 options.

 

1. Upgrade from 2.2-MS2 to 2.3.1 using the upgrade document. This looks beyond my capabilities and would mean updating all my contributions etc. (some of which it may not be possible to). I could pay someone to do it but to be honest I can't really afford to do that.

 

2. Do what you, Chris have recommended before and simply fresh install 2.3.1. But as far as I'm aware this would mean I would lose all my contributions, the look and feel of my site etc. There would be so much to change from the stock oscommerce it would almost feel like starting all over again and I just can't do that.

 

Is there nothing that I can do even as just a short term fix to get my site working again without having to upgrade to 2.3.1? My site is live with regular orders coming in and I need to just get something sorted out asap.

 

Thanks for your help,

Mark.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...