Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

ssl help in 2.3


dculley

Recommended Posts

I have SSL on my host for years and it is working well with my current site. I followed the 123 ssl help posted on oct 23, 2006 and it a wall. Need help.

 

I need to set it up for check out, and customer information. I followed the 123 guid, when I test it out buy clicking the add to cart it errors out on the server not found.

 

Here is my set up:

 

Catalog/includes/configure.php

 

define('HTTP_SERVER', 'http://www.ladybuggardendecor.com');

define('HTTPS_SERVER', 'https://www.ladybuggardendecor.com');

define('ENABLE_SSL', true); //secure webserver forcheckout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://www.ladybuggardendecor.com');

define('HTTPS_COOKIE_DOMAIN', 'https://www.ladybuggardendecor.com');

 

Catalog/admin/includes/configure.php

 

define('HTTP_SERVER', 'https://www.ladybuggardendecor.com');

define('HTTP_CATALOG_SERVER', 'https://www.ladybuggardendecor.com');

define('HTTPS_CATALOG_SERVER', 'https://www.ladybuggardendecor.com');

define('ENABLE_SSL_CATALOG', 'true'); //secure webserver for catalog module

 

What is it that I need to change?

 

Thanks

Dean

Link to comment
Share on other sites

Well. you do not have a catalog in the root of you site.

 

define('HTTP_SERVER', 'http://www.ladybuggardendecor.com');

I did find one in this folder

 

http://www.ladybuggardendecor.com/rbshop/pg1.html

 

but the add to cart goes right to paypal so this is not oscommerce so what shopping cart are you using and what page give a ssl error??

 

But I gota tell you that this is a very difficult site to find your way around.

 

Can't tell you where your ssl should be. You don't need one with paypal buy now buttons

Link to comment
Share on other sites

@@dculley,

 

Lola is correct, the website address does not resolve to an osCommerce website. However, the domain name is associated with an Active SSL certificate.

 

 

 

 

Chris

Link to comment
Share on other sites

@@dculley,

 

Your cookie settings should be:

 

define('HTTP_COOKIE_DOMAIN', 'www.ladybuggardendecor.com');

define('HTTPS_COOKIE_DOMAIN', 'www.ladybuggardendecor.com');

 

 

 

try that.

 

 

Chris

Link to comment
Share on other sites

Chis

 

I changed the 2 lines to define('HTTP_COOKIE_DOMAIN', 'www.ladybuggardendecor.com');

define('HTTPS_COOKIE_DOMAIN', 'www.ladybuggardendecor.com');

and tested the site. It is working. :sweating: THANK YOU. You have been a big help.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...