Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Languages icon broken


Jay Best

Recommended Posts

I have installed a new language pack, but the flag icon is showing up as broken.

 

When I look at the URL, it is coming up as adding another /includes/languages in the link.

 

http://www.thelalashop.com/includes/languages//includes/languages/vietnam/images/icon.gif

 

I have installed this now 3x but it is still showing as broken, where in the database does the image reside?

 

Cheers,

J

Link to comment
Share on other sites

@@Jay Best,

 

You will have to upload the icon.gif (for your language) to the /includes/languages/XXXXXXX/images/ directory on your server for it to appear on your website.

 

 

 

 

Chris

Link to comment
Share on other sites

I don't think the issue is the missing image (that is not stored in the DB but in catalog/includes/languages/your_language/images/icon.gif)

 

Your issue is the wrong path to the image as you found out your self.

 

Where on your website are the images supposed to appear?

 

By the way, did you ask template monster for support?

Link to comment
Share on other sites

Where on your website are the images supposed to appear?

 

 

I think it is safe to assume that if the current language icon is working from the /includes/languages/your_language/images/icon.gif location that any additional language(s) would use the same path, except language directory name to the new icon.

 

 

 

 

Chris

Link to comment
Share on other sites

Here is your icon

yoursite.com/includes/languages/vietnam/images/icon.gif

 

here is where it is looking for the icon. Check your link in your file.

 

 

yoursite.com/ includes/languages//includes/languages/vietnam/images/icon.gif

Link to comment
Share on other sites

Yep that is the basic issue - the url for just the vietnamese language is what is causing the problem. The English icon links to where it is suppose to eg yoursite.com/includes/languages/english/images/icon.gif

 

Any ideas on where this would be to edit?

Link to comment
Share on other sites

Where did you change the code for the icon.gif. You don't add any code for each icon. oscommerce has code that will look in that image icon folder and select the flags.

 

includes modules boxes bm_languages.php

 

replace with unmodified code.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...