Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

which version should I use


Paul101`

Recommended Posts

Hello everyone

 

I am new to this forum and to osCommerce. I have a hosting account with 1 and 1 who offer a one click installation of osCommerce using version 2.2rc2a. The problem with installing through this route is that 1 and 1 put a lot of restrictions on what you can change in terms of template files etc. so I want to upload the files and install it myself.

 

Is 2.2rc2a still available for download or do I have to go with 2.3.

 

My reason for asking is that I am assuming that the rc in 2.2rc2a stands for release candidate and is therefore more stable.

 

Thanks

 

Paul

Link to comment
Share on other sites

2.3.1 is more secure and more stable than 2.2rc2a

 

Your best option is to install 2.3.1

My store is currently running Phoenix 1.0.3.0

I'm currently working on 1.0.7.2 and hope to get it live before 1.0.8.0 arrives (maybe 🙄 )

I used to have a list of add-ons here but I've found that with the ones that supporters of Phoenix get any other add-ons are not really neccessary

Link to comment
Share on other sites

Thanks for that. I have downloaded 2.3.1.

 

I have other sites but have not used osCommerce before so will be back with updates on how its progressing and in all probability to ask more questions.

Link to comment
Share on other sites

2.3.1 is more secure and more stable than 2.2rc2a

 

Your best option is to install 2.3.1

true but majority of modules available for 2.2 version, if you start 2.3.1 you will need to create yourself module or spend money on development. The 2.2 version issues can be easily fix and it can run without any issues.

Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Link to comment
Share on other sites

Thanks for the heads up. Having looked at the downloads page version 2.2 no longer seems to be available to download, however I have checked the addons that I need and they are available for version 2.3 so it should be ok.

Link to comment
Share on other sites

I agree with Alex. Before you get to far into it, you should also try to change the appearance of your shop to be sure you can do that as you want. If you are purchasing a template, it won't matter. But if you are doing it manually, you may find it difficult to get it to appear as you want, depending upon your level of experience.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Good point Jack. I have some experience of modifying templates on Joomla and Subdreamer so I am able to work my way through css, html and php files ok. One thing I have found with osCommerce is that there appears to be a lot of information and help out there when it comes to modifying templates. I have found some video tutorials and a pdf which all look good and go into things in an easy to follow step by step manner so I think modifying the template should be no problem.

 

I am planning to put the site online under a root subdomain from my hosting company and use the "site under maintenance" addon to prevent people trying to order until site is complete. However this does raise a question:

 

Looking at the documentation it says that when you install script it wants a url to be entered in the set up screen. If I use temporary subdomain at set up can I go back and change this in the admin panel later?

Link to comment
Share on other sites

Paul

 

If you want a copy of rc2a or earlier you canget them from my web site, you can find the address in my profile.

 

In answer to your question, if you hard code it in the code, no.

 

Cheers

 

G

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...