Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Deprecated: Function session_is_registered() is deprecated in


ecgbyme

Recommended Posts

Can anyone help to fix this line. New upgrade to PHP 5.3 caused this error.

 

Deprecated: Function session_is_registered() is deprecated in /includes/functions/sessions.php on line 81

 

Appreciate any help!

Link to comment
Share on other sites

Download 2.3.1 from thisi site, unzip the package and inside you will find an upgrade document

Link to comment
Share on other sites

If you follow the upgrade guide you will retain your previous mods (but you might also have to upgrade parts of them so they also are PHP 5.3 compatible) . NOTE: you will not get a "complete" 2.3.1 by doing the upgrade ..None of the of the new extra functions are included, the upgrade is just security, bug fixes and compatibility fixes.

 

I would rather suggest that you make a brand new 2.3.1 shop, modify it to your liking and then import over products/categories/customers/orders from the old shop.

Link to comment
Share on other sites

 

 

Will upgrading to 2.3.1 loose all of my custom setting, all the work that has been done? Would it be like starting over?

 

 

Possibly - but it will give you a store that is more secure than what you are using at the moment and which has been written for php5.3 (which really means php6)

 

If you just starting a store or have not yet gone live you should be using 2.3.1 - it'll be easier now than a couple years down the line with a busy store and finding that you have to upgrade

My store is currently running Phoenix 1.0.3.0

I'm currently working on 1.0.7.2 and hope to get it live before 1.0.8.0 arrives (maybe 🙄 )

I used to have a list of add-ons here but I've found that with the ones that supporters of Phoenix get any other add-ons are not really neccessary

Link to comment
Share on other sites

Possibly - but it will give you a store that is more secure than what you are using at the moment and which has been written for php5.3 (which really means php6)

 

If you just starting a store or have not yet gone live you should be using 2.3.1 - it'll be easier now than a couple years down the line with a busy store and finding that you have to upgrade

 

My store is about 7 years old, tweeked and honed and very secure. Now loosing business daily. I'm so disappointed to find ourselves in this situation. There should be a friendly easy tarnsfer but it looks like a disaster.

You've probably heard this saying before:

 

IF IT AIN'T BROKEN, WHY FIX IT!

 

Very frustrated

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...