Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Use swf movie file on template.


Darren11

Recommended Posts

Hi, I am new here and new to editing templates. I was wondering could someone help me with swf problem. I'm trying to get a swf file playing on my website in the "crayons box".. I found this code for a header and changed it a bit. Would this code work and where would i have to put it?

 

www.Pinnacle-Games.com

 

Thank you for any help,

 

Darren

 

<table width="0" border="0" cellspacing="0" cellpadding="0">

<tr>

<td><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="530" height="213">

<param name="movie" value="http://Pinnacle-Games.com/fade works.swf" />

<param name="quality" value="high" />

<param name="wmode" value="transparent" />

<embed src="http://Pinnacle-Games.com/fade works.swf" width="530" height="213" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" wmode="transparent"></embed>

</object></td>

</tr>

</table>

Link to comment
Share on other sites

Darren,

 

 

Keep it simple:

 

<object type="application/x-shockwave-flash" data="./images/fadeworks.swf" width="485" height="320">

<param name="Squirrel Stuff Video" value="./images/fadeworks.swf" />

</object>

 

 

 

Please the code either in your header.php or your index.php usually.

 

 

 

Chris

Link to comment
Share on other sites

Thank you for the reply Chris, I just have one more question.. I found this in the header.php

 

Line 74: <td><a href="<?php echo tep_href_link('products_new.php')?>"><?php echo tep_image(DIR_WS_IMAGES.'p.jpg')?></a></td>

 

Do i delete that and add what you put? It is the only place i could find the p.jpg crayon picture referenced

 

Thank you,

 

Darren

Link to comment
Share on other sites

I deleted that and got it working to the right side of the template, This is the code i used

 

<td> </td>

<td>

<object classid="clsid:D27CDB6E-AE6D-11CF-96B8-444553540000" id="obj4" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0" border="0" width="513" height="213">

<param name="movie" value="./images/fadeworks.swf" />

<param name="quality" value="High">

<param name="wmode" value="transparent">

<embed src="./images/fadeworks.swf" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" name="obj4" width="513" height="213" quality="High" wmode="transparent"></object>

 

My only problem now is i can not seem to get it to go transparent around the edges, If you could help with that i would be grateful

 

Thank you ,

 

Darren.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...