Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

secure nonsecure, on customer login page - images not secure


Bazil52

Recommended Posts

When clicking on customer login, a warning of some items not being delivered securely, if I choose no, only deliver secure items, the login page does not display the images, if I choose deliver both secure and non-secure, everything looks fine. I use admin to upload images so that folder needs to be accessible for upload. What do I need to do to fix the problem? Thanks.

Link to comment
Share on other sites

Jerry,

 

There are NO images on the login.php page.....

 

If you have added banners, then you have to change them to https:// to avoid the security warning.

 

 

Chris

Link to comment
Share on other sites

When clicking on customer login, a warning of some items not being delivered securely, if I choose no, only deliver secure items, the login page does not display the images, if I choose deliver both secure and non-secure, everything looks fine. I use admin to upload images so that folder needs to be accessible for upload. What do I need to do to fix the problem? Thanks.

Sounds to me like the store isn't recognizing that SSL is on.

 

Can't say for sure without the URL though.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Just as I suspected.

 

Click the SSL Implementation Help link in my signature.

 

Read the first post closely. It has things to check and try.

 

If you need more help please post in that thread not this one.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Thanks germ, the problem was that I am on a Windows server and needed to change the application_top.php to

$request_type = ($_SERVER['HTTPS'] == 'on') ? 'SSL' : 'NONSSL';

I did read through your ssl implementation help before posting, just quit after checking the configure.php file and didn't check everything you had listed. Thanks again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...