Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Customer Shipping/Billing Address Problem


JoshBowe

Recommended Posts

Hi,

 

I've got a bit of a problem with my osCommerce store. When a customer signs up an account and enters their address, if they use commas to separate lines of the address the order comes through to the Orders page in the admin area without anything after the commas in the shipping and billing addresses.

 

For example, if a customer wrote:

 

John Doe,

Flat 1, The House, The Road

Area, Town

City

Post Code

County

Country

 

When viewing an order in the admin area it would show that as the customer address, but as the shipping and billing addresses it would show:

 

John Doe,

Flat 1, The House

Area

City

Post Code

County

Country

 

This lead me to believe that it was cutting off anything after the commas. So I tried entering the address with no commas as:

 

Flat 1 The House The Road

Area Town

City

Post Code

County

Country

 

When I did this it showed the address properly under the billing/shipping addresses.

 

Does anyone have any ideas why this happens and how to prevent it?

 

Thanks.

Link to comment
Share on other sites

nope ... obviously it does not cut off after a comma, or your flat 1 would stand alone ...

 

has your code been changed? I'd compare the order class code in admin with a vanilla file. also - do you have the same issue in your catalog (history section)?

:-)

Monika

 

addicted to writing code ... can't get enough of databases either, LOL!

 

my toolbox: Textpad - Compare and Merge - phpMyAdmin - WS_FTP - Photoshop - How to search the forum

 

Interactive Media Award July 2007 ~ category E-Commerce

my advice on the forum is for free, PMs where you send me work are considered consultation which I charge for ...

Link to comment
Share on other sites

Hi Monika, thanks for the reply. :) I knew it wasn't cutting off after the first comma, but still wasn't sure.

 

The code has been changed apparently, someone worked on it before I did so I wasn't sure but I just compared the code for my classes file and a fresh install classes file and there's big blocks of code missing in my file. Hopefully this will solve the problem, I'll let you know how I get on.

Link to comment
Share on other sites

Narrowed down the problem I think.

 

The problem is coming when customer's pay with PayPal's express checkout (where you don't have to create an account on my website), their PayPal address isn't importing into osCommerce properly. Any ideas?

Link to comment
Share on other sites

nope sorry ... this is stuff that I can only debug myself by adding tons of debug code and testing a gazillion times ;-)

:-)

Monika

 

addicted to writing code ... can't get enough of databases either, LOL!

 

my toolbox: Textpad - Compare and Merge - phpMyAdmin - WS_FTP - Photoshop - How to search the forum

 

Interactive Media Award July 2007 ~ category E-Commerce

my advice on the forum is for free, PMs where you send me work are considered consultation which I charge for ...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...