Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

How can I replace "Buy Now" buttons with "Add to Cart" buttons?


ggrant3

Recommended Posts

I would have thought it the underlaying code at fault and not the actual buttons Greg.

what is your URL please for us to experience your problem first hand.

 

I wouldn't be surprised that it is the code itself. I now these worked fine before, because I have tested sales this way in the past.

 

I am thinking I "tweaked" something during a contribution, but I haven't noticed this issue till recently so I don't know which file modification could be the cause. I probably changed/erased something I shouldn't have.

 

The site is www.bestmadeflags.com

 

To recreate the issue do the following:

  • Click on a category (example: American Flags)
  • then a subcategory (example: Nylon American Flags)
  • Then a list on flags appear with Buy Now buttons, click one of the buy now buttons
  • It takes you to the shopping cart saying your cart is empty.
  • Now repeat the above process (without closing your browser).
  • It now works
  • It will now take you to your shopping cart with one of the items you chose and seems to work fine.

If you close your browser and reopen it and try this all again you will have the same results. The first Buy Now button action is ignored.

Link to comment
Share on other sites

I just tried and it works fine for me

 

Really? On the first attempt it worked for you?

 

I wonder why I am having a problem with it.

 

I have tried it with Firefox and IE at my office and at home and those buttons never work on the first attempt. I always have to go back and click on them again for it to add the item.

 

I was worried it would be a nuisance to those customers that aren't good at navigating websites and they might find things too difficult and move on.

Link to comment
Share on other sites

I have the same problem.

The first product you want to enter from the product listing is not added to the cart.

If you go into the product (product_info) then adding to the cart works fine.

 

It looks like it has something to do with the session. Once the cart has been filled and emptied again, it works fine for that session.

 

It seems only to happen with Firefox and Chrome.

Explorer 8 seems to work fine.

 

Willem-Jan

Link to comment
Share on other sites

I have the same problem.

The first product you want to enter from the product listing is not added to the cart.

If you go into the product (product_info) then adding to the cart works fine.

 

It looks like it has something to do with the session. Once the cart has been filled and emptied again, it works fine for that session.

 

It seems only to happen with Firefox and Chrome.

Explorer 8 seems to work fine.

 

Willem-Jan

 

You have the same problem with your site or when you try mine?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...