Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help! Site just went live and is producing errors


DerekSerianni

Recommended Posts

Hi,

 

I just went live with my site and I thought everything was working fine.

 

Got our first order and a couple things happened:

 

1) No e-mail from osCommerce telling me I had an order

2) Got the PayPal e-mail, money came in fine, but under description it is blank... so I have no idea what the person ordered.

3) When I go to the admin site and click on "Orders" I get this error:

 

Parse error: syntax error, unexpected T_VARIABLE, expecting T_FUNCTION in /home/subaru/public_html/store/admin/includes/classes/order.php on line 43

Line 43 is:

 

$this->info = array('currency' => $order['currency'],

 

 

So I am thinking it has something to do with my currency choice.

 

I am operating the store as "Canadian" as default.

 

The only modifications I made were:

 

1) Installed the Canada Post Shipping Module

 

2) Installed a custom theme

 

 

I reviewed all my changes and everything checks out.

 

 

Any ideas?

 

D.

Link to comment
Share on other sites

To further this.....

 

In the instructions for the Canada Post Module I was to edit my SQL file with this info:

 

INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added, use_function, set_function) VALUES

('Unit Weight', 'SHIPPING_UNIT_WEIGHT', 'KGS', 'By what unit are your packages weighed?', 7, 7, '2008-02-01 09:34:15', '2008-02-01 09:33:58', NULL, 'tep_cfg_select_option(array(''LBS'', ''KGS''),'),

('Unit Length', 'SHIPPING_UNIT_LENGTH', 'CM', 'By what unit are your packages sized?', 7, 8, '2008-02-01 09:34:20', '2008-02-01 09:33:58', NULL, 'tep_cfg_select_option(array(''IN'', ''CM''),'),

('Set Order Status When Shipped', 'SHIPPING_STATUS_ID', '1', 'Set the status of orders shipped to this value', 7, 9, '2008-03-25 06:19:58', '2007-08-12 08:33:31', 'tep_get_order_status_name', 'tep_cfg_pull_down_order_statuses(');

 

ALTER TABLE products

ADD products_description_short VARCHAR( 64 ) NOT NULL,

ADD products_tariff VARCHAR( 32 ) NOT NULL,

ADD products_length DECIMAL(6,2) DEFAULT '12' NOT NULL after products_weight,

ADD products_width DECIMAL(6,2) DEFAULT '12' NOT NULL after products_length,

ADD products_height DECIMAL(6,2) DEFAULT '12' NOT NULL after products_width,

ADD products_ready_to_ship ENUM('0','1') NOT NULL default '0' after products_height;

 

ALTER TABLE manufacturers ADD countries_id INT NOT NULL ;

 

ALTER TABLE orders ADD cp_tracking VARCHAR( 18 ) NULL ;

 

 

I am not 100% sure I did it correctly.... is there any way to see if this worked?

 

Wondering if this could be the issue?

 

D.

Link to comment
Share on other sites

I am not 100% sure I did it correctly.... is there any way to see if this worked?

Go into phpMyAdmin and look at the 'structure' of the 3 modified tables (products, manufacturers, orders) and see if the changes you made show up. E.g., "orders" should have a field named "cp_tracking" that is a VARCHAR( 18 ) and allows NULL. Browse the "configuration" table to see if the three new rows you entered are there.

 

When you say, "edit my SQL file", you are aware that it's a database, not a file? If you merely edited an .sql file, nothing will have happened to your database. You would have had to use phpMyAdmin to either "import" that segment of SQL code, or do it manually through phpMyAdmin's table browse/edit functions.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...