Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem with Easy Populate, a CSV file, and a Mac.


Trentide

Recommended Posts

Hey, thanks for looking at my post.

 

As I said, I'm having a problem uploading the CSV file from a Mac from Easy Populate 2.76i-231. I've saved the file in multiple formats; CSV Windows, CSV MS-Dos, and just a plain CSV file.

 

I've also used BBEDit to save it as a Unix (LF).

 

The file uploads, but my website doesn't reflect the changes I've made. On each of the files that are uploaded I'm receiving this at the beginning: "No products_model field in record. This line was not imported:" I don't know if that has anything to do with it.

 

Also, when saving with Excel I get an error that states - "title of file.csv may contain features that are not compatible with CSV"

 

Also there seems to be a compatibility problem when I run a compatibility check. Excel states: "Formulas that perform calculations on dates might not produce the same results in Excel for Windows. I think, basically, they're saying that PC's and Macs use different ways of calculating dates. I've changed the date to a Windows format in preferences with no results.

 

Any ideas?

 

Thanks again for taking the time to read my post!!

 

Jason

Link to comment
Share on other sites

I've made some progress. Where it says "No products_model field in record. This line was not imported" I just added a "1" for the model number and it imported that product only. But now in my new product there's a "1" underneath the products name. How do I fix that?

Link to comment
Share on other sites

What server (Linux or Windows) are you on? It sounds like perhaps the file isn't formatted correctly on the server. You must upload a CSV file as "ASCII" (text), not binary. Are you doing that? You want the file to be normal text (NL or CRLF line ending) on the server, not Mac format (CR?), and should be able to browse the CSV file as a normal text file on the server. If all of that checks out, then no idea. Maybe the source of your CSV file is not delimiting the fields as expected (missing quotes, or not the expected separator character: tab, comma, etc.). I haven't installed Easy Populate, so I can't tell you exactly what it's looking for. However, I would think the desired format information would be in the EP documentation and/or configuration.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...