Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can't login to Admin--Tried suggestions on forum


arkisaeo

Recommended Posts

I did a fresh install of 2.3.1 yesterday (downloaded from oscommerce.com). The install was successful, but I haven't been able to login to the Admin panel at all.

 

When I try to login, I get the "Error: Invalid administrator login attempt" message.

I've truncated the administrator table/info in phpmyadmin and created a new name/password. I still get the error message.

 

Here's everything that's been tested so far (and has not worked):

 

-Cleared browser (FireFox) cache/history/cookies etc.

-Restarted computer.

-Truncated administrator table in PHPMyAdmin and created new name/password

-Checked/edited configure files (only possible issue with that was the cookie path/info)

-Added htaccess

-Removed htaccess

-Commented out these lines of code in admin/includes/application_top.php:

$redirect_origin['auth_user'] = $HTTP_SERVER_VARS['PHP_AUTH_USER'];

$redirect_origin['auth_pw'] = $HTTP_SERVER_VARS['PHP_AUTH_PW'];

 

Are there any other possible options? From what I remember from the forum/google searches, most of these options came up in other posts (or redirects to other posts), but I haven't found anything other than them.

 

Are there any other files that need to be edited?

Link to comment
Share on other sites

  • 2 weeks later...

I'm having the same problem. I've followed every piece of advice I can find, including patching some of the PHP files in the installation package according to instructions, deleting the admin database record and starting over, finally doing a clean reinstall yesterday. Same result - no admin access. Now I am trying to revert to 2.2, only to discover to my horror that I didn't keep my original installation package.

Link to comment
Share on other sites

Still experiencing the same problem.I transferred my website from my local pc to my online website server but after that am not able to login to my admin area using the very same details which are still working very well on my local pc. have not been able to workout the solution....please can someone help??

Link to comment
Share on other sites

  • 4 weeks later...

I am also having this problem on one of our websites where we cannot login to the admin. I have tried updating administrators, resetting the username and password to the original 'admin', checked permissions settings. Hackers shut us down on this one and we had to run backups through our hosting company. Could this be something residual from that occurrence?

 

Would the kind sir ( username: Taipo ) that provided great security info on hacking issues and OSC_sec please respond?

 

Anyway, the host restored our files and settings to a date prior to the hack that was stored in their archives. We were able to get everything back from there, but this is a strange problem with just this one site and the admin login. Please post if you find the answer, I will keep researching as well, and try to replace some files with the files that are allowing us to successfully login on our other websites.

Link to comment
Share on other sites

What version of osC_Sec were you running on your site Steffani?

- Stop Oscommerce hacks dead in their tracks with osC_Sec (see discussion here)
- Another discussion about infected files ::here::
- A discussion on file permissions ::here::
- Site hacked? Should you upgrade or not, some thoughts ::here::
- Fix the admin login bypass exploit here
- Pareto Security: New security addon I am developing, a remake of osC_Sec in PHP 5 with a number of fixes
- BTC:1LHiMXedmtyq4wcYLedk9i9gkk8A8Hk7qX

Link to comment
Share on other sites

I have the most recent update to os_sec for 2.2 I wanted to update the site to 2.3, but so many of the contribs we had which kept the main features of our site operating, were not available for 2.3. If it ain't broke, why fix it? I guess it's a little broke at this point. I tried replacing my create_acccount, and login files with past versions to see if that was the prob. I don't this so. I think it has something to do in application_top. I will keep plugging. Please share ideas or possible solutions if you get them.

Link to comment
Share on other sites

  • 2 months later...

Button ? What button ?

 

 

The admin area is usually www.yourdomain.com/admin/ or www.yourdomain.com/catalog/admin/

 

Then, type in your username and password and hit enter

 

 

Chris

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...