Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

"Product not found!" message


swarder

Recommended Posts

Hi, any help on this topic is greatly appreciated!

 

The "Product not found!" message is displaying when I click "Add to Cart" from the product info page on my OSCommerce shop.

 

I can get around the problem by setting it up to go straight to the cart when "Add to Cart" is clicked, but I want to stay on the product info page.

 

I have little experience working in PHP - I know is what I have picked up while working on this shop.

 

However, as far as I can tell, the problem isn't in the product_info.php page as the page displays fine when the customer first navigates to it, and I have tried replacing this file with the original from my original download of OSCommerce.

 

Any ideas on how to fix this? Or can anyone even just suggest related files where I might find the error?

 

Many thanks in advance,

 

Simon

Link to comment
Share on other sites

Thanks

 

That did help, but indirectly - I managed to find out a little bit more about the problem and realised I could fix it by slightly modifying the urls

 

The only way I could find to change the urls was to install SEO urls, which has fixed the problem completely

 

I still don't really understand what the problem was or where it occurred but it's gone now so I'm not too bothered!

 

Thanks

 

Simon

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...