Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Will new code work with my OLD oscommerce?


OceanRanch

Recommended Posts

I want to install the latest PayPal module but think I might have a problem with my version of oscommerce. I'm planning to upgrade next year but need to get PayPal running with current system.

 

I am running an old version of oscommerce, this is the version in application_top "application_top.php,v 1.272 2003/03/31 ".

 

I downloaded the zip 2.3.1 and see all the files. However the catalog/ext/modules/payment/paypal/standard_ipn.php is in the EXT directory and my version of oscommerce does not have an EXT directory. If I install the file in my catalog/includes/modules/payment directory then the

 

chdir('../../../../');

require('includes/application_top.php');

 

code will fail because the chdir will cd one directory back to far and the subsequent require will fail.

 

Can I just change the chdir to chdir('../../../'); or am I opening a can of worms.

 

Any additional recommendations or gotchas are appreciated.

 

Thanks in advance

 

Tom

Link to comment
Share on other sites

I suggest you download the Paypal Standard addon from the contributions section and install it. It is the same one that is in 2.3 but it doesn't contain 2.3 related files. It will work fine with your version of oscommerce.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...