Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Customers can't login


CJ Dennis

Recommended Posts

I'm in the process of migrating imagemelbourne.com.au to a new server. The new (temporary) address is secure.imagemelbourne.com.au. Whenever I try to login on the new site it silently fails and takes me back to the main page. There don't seem to be any cookies being set by the new site. Any suggestions on how to fix this quickly? It needs to be working in a couple of days.

Link to comment
Share on other sites

Daniel,

 

 

Check your session settings in admin>> configuration.

 

 

Also, is the new server running the same PHP and MySQL versions as the old server ? What version of osCommerce is the website ?

 

 

 

 

Chris

Link to comment
Share on other sites

Check following:

1. Is SSL set to on for new site.

2. Configuration file is modified for the new url.

 

If yes then check whether cookies are getting created for session id or not.

If no cookies getting createdfor oscsid then is url carrying oscsid.

 

 

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

DunWeb: Everything in sessions is set to false except "Session Directory" which is /tmp. This is the same on both servers. Both servers are running PHP 5.2.17. I'm not sure what version of osCommerce it is but it is copyright 2003. The MySQL version is newer on the new server but I'm not sure which versions the new and old server are running. What now?

 

satish: The new site is using SSL and it's working fine. I have updated the config file with the new details (it wouldn't work at all otherwise, e.g. wrong addresses, 404 errors, no MySQL access).

Link to comment
Share on other sites

Sessions should be as follows:

 

Session Directory........... /tmp

Force Cookie Use .......... False

Check SSL Session ID .... False

Check User Agent....... False

Check IP Address ....... False

Prevent Spider Sessions ...... True

Recreate Session........ True

 

 

To check osCommerce versions, open /includes/application_top.php and look for this around line 37:

 

// define the project version

 

Directly below that line, is your store version.

 

Versions prior to RC2a MAY be written for PHP4.x and could be atleast part of the reason for the issues you are encountering.

 

 

 

 

Chris

 

 

 

 

Chris

Link to comment
Share on other sites

Does anyone know why this is happening and how to stop it? It appears that the session ID is regenerated after login, losing cart contents and login info (thereby asking you to log in again). If you're not logged in it will let you add multiple items to the cart without forgetting them.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...