Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Upgrade 2.2MS2 to 2.3.1


North Bay Made

Recommended Posts

I'm working on a site for friends, and have worked a little with osCommerce in the past. I'm wondering what the best way to upgrade is? I haven't found one complete source or guide. Maybe I haven't looked hard enough :)Any help is appreciated... Thanks!!

Link to comment
Share on other sites

I'm working on a site for friends, and have worked a little with osCommerce in the past. I'm wondering what the best way to upgrade is? I haven't found one complete source or guide. Maybe I haven't looked hard enough :)Any help is appreciated... Thanks!!

http://www.oscommerce.info/confluence/display/OSCOM23/Upgrade+Guides

Link to comment
Share on other sites

  • 2 weeks later...

I need to do this myself as I (occasionally) maintain an online shop as well. The upgrade guide says you need to install RC2a first but it doesn't say where to get it from or any details of how to do it. Does it really involve editing lots of individual files or are those just the change log?

Link to comment
Share on other sites

Yes, you need to edit a lot of files. Since you didn't say what version your current store is, it's impossible to give more concrete instructions.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

It is MS2. I know some of the files have been modified and there are a few extra modules installed. What size of task is it to update it to RC2a, and how complicated is it from there onwards? I've been putting off for a while but I really need to get it sorted out.

Link to comment
Share on other sites

Marcus,

 

 

There is NO upgrade path from MS2 to 2.3.1. You would have to update to RC1 then RC2 then RC2a and THEN to v2.3.1. Keeping in mind that you have to update all of the contributions for each version as you go.

 

It is NOT worth the time and effort to do this, you would be better off creating a NEW store with 2.3.1. In my experience, those who choose to update from prior versions to 2.3.1 have ended up, for one reason or another, having unstable carts once the update is complete.

 

 

 

 

Chris

Link to comment
Share on other sites

There is an easier way: There is an upgrade from 2.2MS2 to RC2a, and another from there to 2.3.1. Then, of course, upgrade all of the contribs, if such upgrades even exist. As Chris said, it's not worth the time and effort. Start over with 2.3.1 and add in what you need.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...