Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Lost access to admin - HTTP 500


Guest

Recommended Posts

Hi,

 

My first post and apologies in advance if this has already been covered. I've seen this discussed before but seemingly without resolution :(

 

Basically, I applied for SSL for a shop and once advised it was in place I amended the includes/configure.php and the admin/includes/configure.php to facilitate the SSL.

 

So, the admin/includes/configure.php was amended to look like this -

 

define('HTTP_SERVER', 'http://www.evolutionkites.co.uk'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.evolutionkites.co.uk');

define('HTTPS_CATALOG_SERVER', 'https://www.evolutionkites.co.uk');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

define('DIR_WS_ADMIN', '/admin/');

define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);

define('DIR_WS_CATALOG', '/catalog/');

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

I have obviously made the same amendments to the includes/configure.php but the actual shop seems to work OK So I'm happy with the changes there. However, I receive an HTTP 500 error when trying to access the admin! I just cannot work this out....

 

My hosts insist that the database and links are fine so it has to be something to do with the rfecent code changes to admin/includes/configure.php file (or perhaps the SSL).

 

Any ideas?

 

thank you

Link to comment
Share on other sites

Can anyone help here?

 

Seems like this is a common problem but rarely produces an answer :(

 

I changed the config files back and the admin still doesn't work - HTTP 500 error received each time.

 

I'd be grateful for any help...

 

TIA

Link to comment
Share on other sites

I think I have managed to pinpoint the error -

 

PHP Warning: require(/catalog/includes/classes/action_recorder.php) [function.require]: failed to open stream: No such file or directory in /home/sites/evolutionkites.co.uk/public_html/admin/includes/classes/action_recorder.php on line 13

 

PHP Fatal error: require() [function.require]: Failed opening required '/catalog/includes/classes/action_recorder.php' (include_path='.:/usr/share/pear5') in /home/sites/evolutionkites.co.uk/public_html/admin/includes/classes/action_recorder.php on line 13

 

The line this refers to is:

 

require(DIR_FS_CATALOG . 'includes/classes/action_recorder.php');

 

This file is definitely in place and access levels appear to be fine?

 

What is happening here?

 

TIA

Link to comment
Share on other sites

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT);

 

Have you tried replacing the $DOCUMENT_ROOT with the absolute path?

 

Should look like /home5/onlinecd/public_html/catalog/

 

This being your location on the shared server from your host.

 

Breaks down like this--- / The Directory The Host Gave You / Your User Name With the Host / Path to Public Html / Catalog Folder

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...