Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL EV and images / logos / links


comportamiento

Recommended Posts

Hello,

 

I just recently applied an SSL EV certificate to one of my osCommerce sites. The provider of the certificate, however, notified me that I would not be able to see the green EV bar to the left of the URL until I "included all images via HTTPS or anything else that displays on the site such as videos/logos/etc." I went through and appended the following code to any place I could find an .htaccess file within the site files... My hope here was to append an "https://" to any link within the site, regardless of whether it was an image or not...

 

"

RewriteEngine On

RewriteCond %{HTTPS} off

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

"

 

This looked nice because browsing to theosustore.com forwarded to https://theosustore.com, however, the green EV bar still doesn't show and the internal links are all still pointed to "http://". Is there anything I can do from the admin panel or on the server to get this functioning properly?

 

Thanks in advance!

Justin

Link to comment
Share on other sites

From the page source:

 

<meta name="generator" content="CRE Loaded v6.2 B2B[12]">

That isn't supported here.

 

They have their own support forum.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...