Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Admin page wont let me log in.


Lovelock

Recommended Posts

i've had to do this in my admin. It works, but might not be an approved method to get around the password problem. If no one post a better solution you can give it a try.

 

 

Open phpmyadmin on your server (should be in your site control panel). List the databases. Make sure you are in the oscommerce database. Choose administrators. Check the entry for your username, delete it. If there are more than one you will have to delete them all. Go back to oscommerce admin. It will say there are no administrators set. Enter your user name and password on the login page. You will have to login twice. The first time it will save your info, the second time it will log you in.

Link to comment
Share on other sites

I followed the above. Created new administrator first time, the logged in second time and get this error:

 

Error Error: The maximum number of login attempts has been reached. Please try again in 5 minutes.

 

I went back into PHPadmin and deleted again and same thing as above. The password in PHPadmin is a bunch of random letters/numbers/symbols.

 

Thanks for any help!

 

Faithfully,

 

Dawn

Link to comment
Share on other sites

I followed the above. Created new administrator first time, the logged in second time and get this error:

 

Error Error: The maximum number of login attempts has been reached. Please try again in 5 minutes.

 

I went back into PHPadmin and deleted again and same thing as above. The password in PHPadmin is a bunch of random letters/numbers/symbols.

 

Thanks for any help!

 

Faithfully,

 

Dawn

 

By default you're only allowed to try and login 5 times before the system locks you out. This helps to prevent brute force admin login attempts. As for the password in the database that is not really your password that is an encrypted value stored in the database. Your password is the password you entered when you create the admin.

 

Even after you truncate the table and go back to oscommerce and make a new login / password you still will have to wait the 5 minutes to login.

Link to comment
Share on other sites

  • 3 weeks later...

My site has been hacked and I was advised to change my password. I have run the sql command which has cleared my admin password file but I am not asked to create a new password when I access oscommerce admin. Can you tell me where I should be able to recreate a new user ID and password. Thanks

Link to comment
Share on other sites

My site has been hacked and I was advised to change my password. I have run the sql command which has cleared my admin password file but I am not asked to create a new password when I access oscommerce admin. Can you tell me where I should be able to recreate a new user ID and password. Thanks

 

 

you have to truncate you administrator table..

 

if no records found in administrator table then only you have asked to create new user

 

so make sure your administrator table is totally blank... no data is there.

Please take backup of your files before do changes suggested by me

Link to comment
Share on other sites

truncat your administrators table, the action_recorder table and the sessions table.

Then, you can create a new admin username and password..

 

Same problem over here, We cannot login to the administrator area.

 

I've tried the above, but when logging in after creating a new administrator and password, I get still the message "Error: Invalid administrator login attempt."

Now I am at a complete loss!!!

 

Please help!

Link to comment
Share on other sites

i have the same problem too, i cannot log in to my admin page no matter how many times i tried, it keep showing the follwoing messages:

 

Warning: require(includes/languages/.php) [function.require]: failed to open stream: No such file or directory in D:\Hosting\8202570\html\admin\includes\application_top.php on line 167

 

Fatal error: require() [function.require]: Failed opening required 'includes/languages/.php' (include_path='.;C:\php5\pear') in D:\Hosting\8202570\html\admin\includes\application_top.php on line 167

 

but i checked my server, and the file application_top.php still exist...can anyone please help? thx in advance!!

Link to comment
Share on other sites

require(includes/languages/.php) your code is not getting value for language.

 

This is register globals issue and you need to apply fix so that session variable $language value is available.

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...