Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Home page not displaying correctly


semper-linux

Recommended Posts

Hi Forum,

 

I recently uploaded my website (from home pc to web server) but, when I try to access the site ( www.custompc.ch ), I keep getting the following lines printed out at the top of the home page........

 

Warning: session_save_path() [function.session-save-path]: open_basedir restriction in effect. File(/var/www/custompc/public_html/catalog/includes/work/) is not within the allowed path(s): (/mnt/sites/custompc.ch:/tmp:/usr/local/anti-spam:/usr/local/lib/php) in /mnt/sites/custompc.ch/web/catalog/includes/functions/sessions.php on line 169

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /mnt/sites/custompc.ch/web/catalog/includes/functions/sessions.php:169) in /mnt/sites/custompc.ch/web/catalog/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/sites/custompc.ch/web/catalog/includes/functions/sessions.php:169) in /mnt/sites/custompc.ch/web/catalog/includes/functions/sessions.php on line 102

 

 

 

I've modified both configure.php files and neither contain any references to the old paths. If you read the first line of the error message, there is still a reference to the home pc paths - " File(/var/www/custompc/public_html/catalog/includes/work/) is not within the allowed path(s): "

 

The error is quite correct as that path does not exist on the web server.

 

I've hunted high and low to find this entry but cannot find it anywhere - I'm sure if I find it and correct it to the web server path, the error will disappear and site access should be OK.

 

However, I could easy be wrong.

 

Anybody got any ideas on this one ?

 

semper-linux

Link to comment
Share on other sites

Hi Forum,

 

Thanks for your reply KDM.

 

The .htaccess has no restrictions in it - in fact it has no commands at all - just comments.

 

I checked out your link - that posting ascertained the site had been hacked but there's no sign of that in my system - the index.php file is fine - original state.

 

The error is happening because the system can't write the session data - that's because it has this invalid path.

 

Question is, "where is it finding this path reference ?"

It's not from the configure.php files - they've been checked and re-checked 1000 times.

 

Anyone know the function of the 'Work' directory (which I have set to write-enabled - 777) ?

 

I've also checked the 'Sessions' table in the database but nothing there either.

 

HELP !!?**!?!

 

semper-linux

Link to comment
Share on other sites

Check /catalog/includes/ local and /catalog/admin/includes/ local folder for a configure.php file that's interfering with the normal configure.php file(s).

 

If you find one, get rid of it or rename it.

Link to comment
Share on other sites

Hi Forum,

 

Thank you Multimixer and BryceJr for your replies.

 

BryceJr - I checked and both directories have only a README file in them.

 

multimixer - Because of the error, I can't log in to the live site admin - if you'd like give it a try and see what happens ( www.custompc.ch/catalog/admin/login.php ).

 

HOWEVER, I have a local copy on my pc and guess what - the path for the session directory is....." /var/www/custompc/public_html/catalog/includes/work/ " - BINGO !

 

Question is, where is that path stored ? - it's not in either of the configure.php files.

 

Any pointers most gratefully received !

 

many thanks,

 

semper-linux.

Link to comment
Share on other sites

...

Question is, where is that path stored ? - it's not in either of the configure.php files.

 

Create a folder(call it "work") inside your catalog directory and give it 755 permission.

 

Log in to your PhpMyAdmin >> follow the screenshots

 

On the third screenshot where it says /tmp, yours will indicate "/var/www/custompc/public_html/catalog/includes/work/".

 

Change that to /mnt/sites/custompc.ch/web/catalog/work . Save it .

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...