Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

wrong url creation on link generated by oscommerce site


roboamg

Recommended Posts

Hi

 

My site was hacked and I think I have cleaned my site deleting the additional php files and java scripts.

 

However i should have missed something since my site generates erroneous url such as

 

http://uniservaviati.../action/success

 

 

where I would expect

 

http://uniservaviati...?action=success

 

 

Does any one have any idea why this is happening? Doies it has tod o with the .htaccess file? What could caus this wrong creation of url/ Any one have faced a similar issue?

 

Thanks

Link to comment
Share on other sites

I think many people who have been hacked have had this problem, or one similar. The answer is the same - meticulously go through all your files removing any script that is not part of the osC program. Then apply all security patches and additional security programs.

 

Or you could completely wipe your website then install 2.3.1 and import your database into it and then add additional security programs.

 

Have a look in the security forum for more posts on the subject

My store is currently running Phoenix 1.0.3.0

I'm currently working on 1.0.7.2 and hope to get it live before 1.0.8.0 arrives (maybe 🙄 )

I used to have a list of add-ons here but I've found that with the ones that supporters of Phoenix get any other add-ons are not really neccessary

Link to comment
Share on other sites

Hi

 

My site was hacked and I think I have cleaned my site deleting the additional php files and java scripts.

 

However i should have missed something since my site generates erroneous url such as

 

http://uniservaviati.../action/success

 

 

where I would expect

 

http://uniservaviati...?action=success

 

 

Does any one have any idea why this is happening? Doies it has tod o with the .htaccess file? What could caus this wrong creation of url/ Any one have faced a similar issue?

 

Thanks

In your Admin, set 'Use Search-Engine Safe URLs (still in development)' to false.

 

Save it.

 

Sometimes you have to set 'Use Cache' to false (or clear the cache in the admin) to see any change.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...