Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Blank Spaces in product listings.


BlazeSama

Recommended Posts

Hi,

 

First of all, I've been trying to find for a solution to this problem myself for a couple of hours with no luck, so if this problem was already posted, sorry for creating a new post.

 

I'm trying to set up a website, Oscommerce 2.x, and everything was going just nice until I tried expanding the amount of products listed in the front page and other categories from 6 to 16.

 

My Website

 

Take a look at my homepage and you'll notice almost instantly if you scroll down whats my problem, if you check my categories it also happen there...

I want to get rid somehow of these blank spaces, and I'm wondering if I'm doing something wrong or do I need to configure something else?.

 

 

I need to fix this as soon as possible, I'll appreciate a lot any help on this matter, thanks.

Link to comment
Share on other sites

Some of your product boxes are taller than others, which pushes the next row out of line. Your code is stating width:152px;height:152px; I think you need to increase that height a bit.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

Some of your product boxes are taller than others, which pushes the next row out of line. Your code is stating width:152px;height:152px; I think you need to increase that height a bit.

 

Regards

Jim

 

Hi, thanks for the reply. so, basically I should try increasing the height size.. where should i do this? is it a control panel option or i need to modify any specific PHP file?

 

Thanks.

Link to comment
Share on other sites

I don't know where it is. That code is not in stock osCommerce, so it's something you added. It's probably in a file. The easiest way is to use your computer's Search function to find the text in bold.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

I don't know where it is. That code is not in stock osCommerce, so it's something you added. It's probably in a file. The easiest way is to use your computer's Search function to find the text in bold.

 

Regards

Jim

 

Well thanks anyway, you somehow managed to give me a hint on what do i need to fix, but if someone else have any idea on how i can fix this bug please post, in the mean time ill try to find a solution.

 

also I've checked the stylesheet.css with not luck i know there must be a place to fix this and its actually an easy way the problem is find the file or option i need to change.

 

Edit: I need to add, the width:152px;height:152px; fact is not the problem indeed, i did some changes and that seems to be the image size, i tried increasing and decreasing it with no luck.

Link to comment
Share on other sites

Hi Again, I just want to say that i managed to fix the problem... thanks god, i found this option in Maximum Values "Width of the block of a product" it was set to 228, changed it a bit and decreased it to 220 and the problem went away, but i must say it was thanks to your guiding hinting me in the right direction, thank you so much for the help.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...