Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Firefox issues


HBNdevTeam

Recommended Posts

After the FF5 update I have gotten some weird issues popping up. Mainly around positioning. Anyone know if this a common issue? I have item 1 on the left and item 2 centered on the page, but since the update item 2 has been pushed to the left and item 1 has been set to the right. If anyone can help me I would greatly appreciate it. If their is any other info that you need from me, please let me know.

 

Thank You

Link to comment
Share on other sites

Ok I thought I would be a little more specific with code.

 

This is part of my index.php that is relevant. *I left comments to specify item 1 and item 2*

<?php
 } else { // default page
?>
<!--Everthing from this h1 and the parent div from here is item 2-->
<h1><?php echo HEADING_TITLE; ?></h1>

<div class="contentContainer">
 <div class="contentText">
   <?php echo tep_customer_greeting(); ?>
 </div>

<?php
   if (tep_not_null(TEXT_MAIN)) {
?>

 <div class="contentText">
   <?php echo TEXT_MAIN; ?>
 </div>

<?php
   }

   //include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS);
   include(DIR_WS_MODULES . FILENAME_UPCOMING_PRODUCTS);
?>

</div>

<?php
 }

 require(DIR_WS_INCLUDES . 'template_bottom.php');//This is item 1
 require(DIR_WS_INCLUDES . 'application_bottom.php');
?>

 

The issue that I found was that within template_bottom.php it contained the footer as well as the code for item 1 (a side bar)

 

This is template_bottom.php:

</div> <!-- bodyContent //-->

<?php
 if ($oscTemplate->hasBlocks('boxes_column_left')) {
?>

<div id="columnLeft" class="grid_<?php echo $oscTemplate->getGridColumnWidth(); ?> pull_<?php echo $oscTemplate->getGridContentWidth(); ?>">
 <?php echo $oscTemplate->getBlocks('boxes_column_left'); ?>
</div>

<?php
 }


?>

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

</div> <!-- bodyWrapper //-->

<?php echo $oscTemplate->getBlocks('footer_scripts'); ?>

</body>
</html>

 

The idea that I am running through my head is splitting the template_bottom.php into two seperate files and then specify them into index.php. The only issue is that I dont know how to accomplish this while having everything running smoothly afterwards. I hope this will help me get some answers.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...