Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

error using "PayPal Website Payments Pro" add on


Recommended Posts

We started getting an error today that says "GnuTLS recv error (-9): A TLS packet with unexpected length was received. (Error No. 52)" whenever a customer try's to use a credit card to checkout on our website. We are using the Paypal website Payments Pro add on from dynamoeffects, but it is an old version of it. http://addons.oscommerce.com/info/3647. version 0.9 I believe.


It has been working fine until today, when we noticed a bunch of customers all of a sudden only using paypal as a payment method. I just happened to try and make a sample order on our website doing some other troubleshooting for a different issue and noticed the error. I have been contacting paypal support with no answer so far from them.


I think the issue may have something to do with ipower updating some PHP servers, because we had a different issue yesterday where the admin backend would not work until we updated some code. Luckily that was an easy fix that someone had already posted about. This one has me baffled. Our website for reference is www.digitalpowerpro.com







Edited by digitalpowerpro
Link to comment
Share on other sites

fixed, I figured out the problem with some help of my bro in law. The curl version was not set in the code, so we updated the code with to set it as curl version 3 in our paypal_wpp.php file and then it worked.


Could you be more specific as to how you solved this problem? I am having the same issue but am unclear as to how to fix it based on your solution. Many thanks!



Link to comment
Share on other sites

Solved it -- If anyone else comes across this problem just adding one line fixes it.


Edit /catalog/includes/modules/payment/paypal_wpp.php


Around line 330:


$caller->setOpt('curl', CURLOPT_SSL_VERIFYPEER, 0);

$caller->setOpt('curl', CURLOPT_TIMEOUT, 180);

$caller->setOpt('curl', CURLOPT_SSL_VERIFYHOST, 0);


// Dennis McEntire Feb 2011 - Fixes curl_exec error 52 problem

$caller->setOpt('curl', CURLOPT_SSLVERSION, 3);


Just adding that last line solves the problem.


Hope this helps someone else.


Dennis McEntire

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...