Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

FATAL ERROR: register_globals is disabled in php.ini, please enable it!


Recommended Posts

Hi Everyone,


Im hoping someone can help me here.


Ive downloaded osCommerce off the internet with a theme integrated and ive uploaded it to my shared server and its giving me the the FATAL ERROR: register_globals is disabled in php.ini, please enable it!


Im not sure which version of osCommerce this is but i know that it says v 1.3 in the install.php file so im pressuming this is the version?


Does anyone know how to fix this error or if not is it possible to install the latest osCommerce version and somehow integrate this theme?


Thanks for the help in advace :)

Link to comment
Share on other sites

Your integrated osC+Theme set is using a very old version of osC (2.2 MS2 or older) that still requires PHP to have "register global variables" on. Your best bet would be to find an integrated set that uses the latest version (2.2 RC2a). Failing that, get the current version (2.2 RC2a) from this site and install a theme you like. Your last choice would be to talk with your hosting service about how to turn register global variables "on". If they allow it, it may be as simple as an entry in php.ini or .htaccess. However, this last solution won't last forever, as eventually PHP will be upgraded to the point where you can't enable register globals. It might buy you some time to find an up-to-date version, but if you're just starting out, it's better to do it right, from the start. Besides, osC 2.2 MS2 is way behind the times on bug and security fixes, and may have other incompatibilities with recent PHP versions. If your hosting service is at PHP 5.0 or later, I wouldn't even bother trying to turn on register globals, but would upgrade to the current osC right away.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...