Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

500 Internal Server Error before installation


Recommended Posts

I would have thought this was a no brainer, as no one else seems to be struggling with this.


I've unzipped my oscommerce-2.2rc2a folder, put the catalog folder in my local folder and uploaded it to my public_html folder on the server. I've changed permissions on all the folders to 777 (also tried 755) and have deleted the htaccess file in the root directory, but to no avail. Everytime I try to go to www.catt....com.au/catalog/install i get this error:


"Internal Server Error


The server encountered an internal error or misconfiguration and was unable to complete your request.


Please contact the server administrator, webmaster@cattlemansreserve.com.au and inform them of the time the error occurred, and anything you might have done that may have caused the error.


More information about this error may be available in the server error log.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ Server at www.cattlemansreserve.com.au Port 80"


Anyone know why?

Link to comment
Share on other sites

Ok. I seem to have solved that issue. My error log showed it didn't like the public_html file to be writable. So I changed permissions to 755 again and since deleting the htaccess file that seems to have worked. Hope this helps someone else.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...