Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Unable to connect to database server!


magicandmischief182

Recommended Posts

I just switched hosting companies, I've uploaded all of the old files from the old server to the new server. Now when you click

"shop online" you get the "Unable to connect to database server!".

Any help would be appreciated!

www.performanceoffroadcenter.com

 

PS I Know it doesn't say "Powered by OsCommerce" on the home page, but it did on the www.performanceoffroadcenter.com/oscommerce

Thanks to all,

Jeffrey

Link to comment
Share on other sites

you have updated the mysql settings in configure.php files both in admin and shop.

 

Check also if your new host use localhost or need to be correctet to a hostname or ip.

Make sure username, password, db name is correct.

It should say so in your hosting panel where you change mysql settings.

Link to comment
Share on other sites

you have updated the mysql settings in configure.php files both in admin and shop.

 

Check also if your new host use localhost or need to be correctet to a hostname or ip.

Make sure username, password, db name is correct.

It should say so in your hosting panel where you change mysql settings.

I was just checking into all of this. My configure.php file now has a different root, login and password, but I'm still not able to get it to work properly.

Link to comment
Share on other sites

Ok, I've got that working, but now I'm having issues with the back side. When I go to catalog/admin it gives me this

"500 internal server error

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Any advice?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...