Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Make Post code display more characters on order screen


Recommended Posts



I changed the post code field before to be used for Address 3 instead of post code and it seems to display the full name thats in Address 3 everywhere except the admin order editing screen. On that it looks like:


Johnny Doe

Address 11111111

Address 22222222

Address 33



See how Address 33 is getting cut off, it should read Address 33333333 like the other fields. How to i extend that? I've tried changing the db table address_format but no joy. Thanks.

Link to comment
Share on other sites

  • 1 month later...

I also found in customers.php in the admin folder that there's an entry for entry_postcode which had maxlength="10" and i changed that to 32 but still no joy on the order screen, its still shortening the field to only 10 characters! where's the setting for changing this?!?!

Link to comment
Share on other sites

Hi Burt, thanks for the reply. I had actually done that initially changing the character limit on address_book in the db to VARCHAR(32) and that seemed to work for saving new customers so that their post code can store 32 characters and most other places on the site where you'd see the post code field will display the full name in this field.

But in the admin/Orders screen, when you click into an order to edit it, it's still only displaying the post code field under Billing Address and Shipping Address with 10 characters. There's a limit set somewhere for only displaying 10 characters on the post code field on the Orders page, but its not in the places i've tried so far. Weird stuff... any other ideas on keywords to search for in the files/db which may be related to this issue? i tried "10" and "postcode", went through orders.php with a fine tooth comb and still cant spot the problem yet...


EDIT: just noticed on the orders table in the db that there are seperate entries for customers_postcode and delivery_postcode and billing_postcode! Doh! Thats the problem... They were all set to Varchar(10) :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...