Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Amazon S3

Recommended Posts

I'm trying to use the Amazon S3 contribution. There were a few problems when trying to configure things correctly at first but I thought I had everything working after running a few successful tests. However as I've started adding downloads to my store I am now greeted by the following error message when I click on a download link -


NoSuchKeyThe specified key does not exist.Kicking_and_Screaming.mp3D808AC4224C42F97HkdAJgXmSz0cPp1V7YOMOuPXzbufCHWiddhBCbv7M61wlYthz77Ue57lf6K21AbR


I haven't altered anything since I got it working so I'm completely stumped. I tried getting a new Access Key ID from Amazon but I'm still getting the same error message. Can anyone help?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...