Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

www and non-www


qwertyjjj

Recommended Posts

I want users to use the www part of my site and also because google currently lists www and non-www pages.

However, I cannot use htaccess because as soon as I do that, it makes all the login functions on the site fallover.

Any ideas?

 

You have to change both the catalog and admin configure.php files like ..

 

Change ..

 

  define('HTTP_SERVER', 'http://mysite.com');
 define('HTTPS_SERVER', 'http://mysite.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', '.mysite.com');
 define('HTTPS_COOKIE_DOMAIN', '.mysite.com');

 

to ..

 

  define('HTTP_SERVER', 'http://www.mysite.com');
 define('HTTPS_SERVER', 'http://www.mysite.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.mysite.com');

Link to comment
Share on other sites

You have to change both the catalog and admin configure.php files like ..

 

Change ..

 

  define('HTTP_SERVER', 'http://mysite.com');
 define('HTTPS_SERVER', 'http://mysite.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', '.mysite.com');
 define('HTTPS_COOKIE_DOMAIN', '.mysite.com');

 

to ..

 

  define('HTTP_SERVER', 'http://www.mysite.com');
 define('HTTPS_SERVER', 'http://www.mysite.com');
 define('ENABLE_SSL', true);
 define('HTTP_COOKIE_DOMAIN', 'www.mysite.com');
 define('HTTPS_COOKIE_DOMAIN', 'www.mysite.com');

 

Hi

I did that and it disabled all loggin in of customers on the cart.

Must be something to do with the sessions.

Is there anything in the db that needs changing?

Bizarrely it didn't cause a problem for the admin login.

Link to comment
Share on other sites

Hi

I did that and it disabled all loggin in of customers on the cart.

Must be something to do with the sessions.

Is there anything in the db that needs changing?

Bizarrely it didn't cause a problem for the admin login.

 

Well those are the correct settings .. have you cleared your browser cookies?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...