Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Image Upload Permissions Error


Recommended Posts

After uploading a few of the Category graphics for our new installation, I noticed that the images were owned by 'apache' on our server -- and not by my server user name -- which means that I can not delete, change, over-write or otherwise control the images.


I have, of course, had them removed but I can not upload additional images because getting them deleted is a Tech Support Request -- as they are owned by the server daemon 'apache' I must get a server administrator to delete them.


Can you tell me why a mid-February snapshot would contain a bug that affects the file ownership status of uploaded image files?


I can not continue to use the image upload features if they will not be properly owned on the server.


Any insight, help, bug fix recommendations or other useful suggestions most appreciated.


Thanks. :?

Link to comment
Share on other sites

That is strange. My images are listed the same way, but I have no problem deleting them or adding them. Apache is owner and group. But I own the image dir which is set to 777. You might want to check your permissions on your image dir. And if you have further problems, talk to your server admin.



Link to comment
Share on other sites

Thanks for the reply. Our situation are not comparable, since you (apparently) are running your own server -- you said your files were owned by 'apache' process, and that you can manipulate the files on the server file system. That would be vastly different from most users who use Apache vhost set-up for domain hosting.


In that case, the user process is neither 'apache' nor 'root', but a hosting user name.


So...your comparison is not helpful in this case.


However, there is another thread which sheds all the light that is needed, and it can be found here: <http://www.oscommerce.com/forums/viewtopic.php?t=33748>


I have made the suggested change to the BUGGY file and now things work as they should. The image files that are now uploaded via OSCommerce are properly owned by the __same process running the php script__ which should have been the case already.


So...for others (there seem to be some) who have problems with uploaded files having an owner/chmod of 600 -- which is not good if you are not the 'real' server administrator [being the main admin for a domain that is hosted on another server is not good enough here] -- then use the addition suggested to the tep_image_upload function and you will be fine.


For whatever reason, in some configurations, the server will own the images unless you specifically set the permissions on the uploaded files. This fix will help.


Thanks to the original poster in the other thread ... worked like a charm.


Take care all.

Link to comment
Share on other sites

I'm glad you fixed it.


But, to let you know, I am on a shared server that I don't have root access, so there must be a setup difference between your server and mine. It is no big deal, I just glad to see someone get things fixed without too much effort.


I also have my own server, that I test software on, I do understand the ins and outs of permissions. Running Linux Mandrake 9.0


Good luck,



Link to comment
Share on other sites

Steve, thanks for the follow-up.


My reply sounded (on re-reading) a little edgy...just wanted to follow-up myself and say thanks.


You're right, there are so many different possible configurations of servers, virtual hosts, php installs and so forth that it is very often quite difficult to even know what will work, or why something isn't, or even what fixed it when it starts working! :)


That's why your input, and others, is so important for user questions. We all get to move a little further along.


So...thanks for reading the thread and offering your ideas. I'm glad others did as well, and a solution was found. Success.


I wish there were a useful way to get more shared solutions into working documentation for distributions of software, but, alas, documenting is often the last thing done and one of the most important.


Lucky there are boards and a communities of users. Again, take care and happy osCommercing. I'm starting to get the hang of it...I think. Clunk-clunking along anyway.


Over and out.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...