Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Can't do checkout_process


Recommended Posts

I've broken something in the checkout process and it no longer works.


Upon entering the payment information and then clicking on 'continue' all I get is a blank white page when it tries to process it. The corresponding page that I see it try to access is checkout_confirmation.php. Note that it correctly verifies the credit card number/expiration date.


Also, even if I choose an alternate payment method, ie. paypal...upon selecting continue nothing happens.


What should the permissions be for the following directories:




I've currently got it as 755 and if it's anything else, I can't view the corresponding modules in my admin panel.


My main problem is the blank page for hte checkout_confirmation page...if anyone knows what's going on, help would be appreciated, thank you.

Link to comment
Share on other sites

I'm still stuck, and I'm not a PHP code guru. Seeking some help from the pros out there.


I don't know what happened, but my checkout no longer works.


I originally had Bao Nguyen's ADC contri for authorizenet installed, and decided I would un-install and revert to the files from my original snapshop (sometime in the first or 2nd week of November). After reverting 2 files to the backed-up originals, I now have problems with the checkout process even using Paypal.


All I get is a blank screen when I've selected a payment option. Nothing happens.


What are the related files which can affect the checkout confimation step? Is it possible the database has been corrupted? I don't know where to look. I've gone and tried to backtrack, but I'm stumped. Please, someone give me some advice!! Being stuck and not be able to get help from local friends (since I'm the only one using osCommerce) is not fun :(

Link to comment
Share on other sites

My car is making a funny noise can you tell me what it is?


I would suggest you revert back to all of your old saved files and not just 2 and then see what happens. Or at the very least reload your back-up of when the cart was working and try to un-install the mod again.

Link to comment
Share on other sites

Turn on and off your payment/shipping modules if you made code changes and reset them.


You may have different settings in the database than what your payment and shipping classes are expecting to find.

Link to comment
Share on other sites



Fixed my problem(s). I had an issue with file/directory permissions before I discovered this issue. Yesterday, in my admin panel, certain modules would not show up and I would not be able to edit/change any setting. I thought I had fixed up all the file permissions, but I had one lingering problem in my admin/modules/order total. It would only list the options, but I was not able to edit. I didn't realize the importance of this...so I passed up on it and decided to tackle the problem with the blank order processing page.


Well, turns out that it needs the order total to process the transaction. Duuuhhh. I feel soo stupid. With no total, of course it's not going to process anything. And so, since it wasn't able to access the order_total modules...nothing worked.


The posting that finally lit the lightbulb over my head was this one:




Went back and fixed the file permissions. Order total module displays correctly with the 'edit' option.


Now, tested the transaction...and voila! Order confirmed! Geez...this problem had me frustrated all day!! Thanks for the tips and advice...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...