Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HSBC API Module


000---000

Recommended Posts

I've installed the HSBC XML API module, but when submitting credit card details the site redirects to the login page. Any ideas?

 

{I am using a shared SSL, which all seems to work fine up to this point}

oscommerce_community_forums.gif
Link to comment
Share on other sites

but when submitting credit card details the site redirects to the login page. Any ideas?

debug the payment URL, as sounds to me that incorrectly installed something in checkout_confirmation.php file

Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Link to comment
Share on other sites

  • 4 months later...
  • 1 month later...

Help me

HSBC API Istalled

 

In process the credit card look this message

 

Credit Card Error!

Unfortunately there has been a technical problem. Please try again and if the problem persists please contact us ()

 

I am having the same problem. I am entering a real visa electron card for an order of GBP 0.20. I saw on another thread that for the HSBC API, a real card should be used with a total value including shipping of less than one pound. Also I am using STS, but I don't see why this should affect it. Also I have rum the curl_test.php script and I am not receiving any errors. Can anyone help me with this? Thank you.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...