Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Session and URL Issue on migration


kujain

Recommended Posts

Hi folks!

 

I was wondering if you could help with this frustrating issue I have been facing for the past few weeks:

 

I am in the process of migrating my osc install to a new dedicated server (as is) but sessions simply do not propagate there: for each page I visit, a new sesskey row is generated in the sessions table. Of course this means that if I login, the next link I click just logs me out. Same for just any link click. Even refreshing the same page creates a new session for me!

 

I compared server (httpd.conf, php.ini, mysql.cnf etc) and osc config settings line by line and there is literally no difference (except the server/database path etc.). I have changed nothing since the move. The only diff is that the php version is now 5.1.6 as compared to 5.0.4, mysql is now 5.0.45 as compared to 4.1.20 and OSC version is the same: v2.2 RC1.

 

I am using ultimate SEO add-on which worked perfectly on the original server and since I copied the database as is to the new server, the settings are the same on the new server as well.

 

Can someone please help ???

 

Thanks !!

Link to comment
Share on other sites

have you checked your configure.php files for the correct pathfiles?

might be something amiss in there

Nic

 

Thanks for your response Nic!

 

I did check and double-check. Nothing amiss there. Here is a paste of the relevant settings:

 

  define('HTTP_SERVER', 'http://server.com'); 
 define('HTTPS_SERVER', 'https://server.com'); 
 define('ENABLE_SSL', false);

 define('HTTP_COOKIE_DOMAIN', HTTP_SERVER);
 define('HTTPS_COOKIE_DOMAIN',HTTPS_SERVER);
 define('HTTP_COOKIE_PATH', '/tmp/');
 define('HTTPS_COOKIE_PATH', '/tmp/');

 

Before getting here, I had tried this entire process on a completely different server, with the same results. So it seems to me that something in this particular configuration has issues with other servers or with the migration (but it works perfectly on the current one!).

Another thing is the if I turn off Ultimate SEO and sid killer, then the oscid shows up in the url path and it works. But again the current setup still works with both these enabled!!

 

Please help!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...