Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Suddenly lost cart contents


VPSsupport

Recommended Posts

Hi,

 

My cart has been running fine for a long time now but I seem to be losing my cart contents today.

 

Was wondering if someone would kindly take the time to look at http://www.naturallydoesit.co.uk/shop

 

and perhaps give me some pointers?

 

Many thanks

just to add it seems to be selective to which product you select as to when it adds to cart or goes to your cart is empty page - strange!!

 

the url is being re written by an seo modification but this was done some time ago

Regards,

Clive

Link to comment
Share on other sites

Just a guess, but is it only losing products that have attributes/options? If so, your URL rewriter may be messing those up.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

Just a guess, but is it only losing products that have attributes/options? If so, your URL rewriter may be messing those up.

 

Regards

Jim

 

 

thanks for the reply jim - I only have 4 products in total and the one it keeps is the one with product options or is this just coincidence?

Regards,

Clive

Link to comment
Share on other sites

i also agree that the problem here is the code of your .htaccess that deals with mod_rewrite.

 

Thanks for the reply, thats very interesting i have been using my seo mod rewrite mod for a while now and it was handling everything just fine.

 

Although yesterday I did upgrade my testimonial mod, could the problem be pointing to this as from my understanding the upgrade deals with some security issues - could there be a conflict here between mods?

Regards,

Clive

Link to comment
Share on other sites

That's entirely possible. URL rewrite rules can fail if you change the way the dynamic URL is written. This can be very tricky to debug. The easiest way to tell would be to reload your file backup from a time when it was working. If it starts working again, the updates are at fault.

 

Regards

Jim

See my profile for a list of my addons and ways to get support.

Link to comment
Share on other sites

shopping_cart.php?sort=2a&osCsid=8dae67ec48f8d5e1e074907e3500c0bd

 

 

I think the problem will be in includes/functions/general.php

 

 

Didnt notice the &amp - many thanks for spotting that - have updated general.php with the Buy button now fix in Ultimate SEO url contrib. It works how it should now, I really appreciate you guys taking the time to look at the site.

Regards,

Clive

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...