Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

I am getting error no.1064


Recommended Posts

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 0, 30' at line 1

 

SELECT manufacturers_name FROM manufacturers WHERE manufacturers_id = LIMIT 0, 30

 

 

hi guys,

 

I am getting the Above mentioned error in oscommerce.

 

whenever I am selecting any category and after that manufacturer I am getting all the products of that manufacturer in that particular category. but after that whenever I am not selecting any manufacturer I am getting this above mentioned error.

 

please help me out .

Link to comment
Share on other sites

You could try the solution to the "-20" problem, follow the link

 

SQL5 compatibility updates & patches

 

below, might help but couldn't swear to it.

 

G

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

I can't find the code involved, but there's obviously an error in the code that forms the SQL statement. You want to end up with single quotes around the value that manufacturers_id is being tested against, something like:

 

SELECT manufacturers_name FROM manufacturers WHERE manufacturers_id = '5' LIMIT 0, 30

 

In your case, since you failed to give the information that would lead to a particular manufacturers_id being used, it would be = '' instead of = '5'. The code should be checking if no manufacturer was given (or an invalid one was given), so it wouldn't try to do this database query (another error). There was nothing in the error message that said what file and line number was involved? Do you have any contributions installed? What version of osC are you using?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...