Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR: register_globals is disabled in php.ini,


Guest

Recommended Posts

Im getting this error when im trying to install a theme

 

 

The site is working ok as is the admin area

 

 

 

Just so im corrent in thinking, You create a new folder in your root dir for the the theme unzip the contents and try to install in this case mine was http://www....blah blah//1846/1864/install/install.php

 

Im greated with this error FATAL ERROR: register_globals is disabled in php.ini,

 

I have installed the patch, Overwriting the files, also tried creating my own php.ini file and uploading it to all the places that require it, and still no luck.

 

Any idea's what the problem could be??

 

Thanks

Link to comment
Share on other sites

Im getting this error when im trying to install a theme

 

 

The site is working ok as is the admin area

 

 

 

Just so im corrent in thinking, You create a new folder in your root dir for the the theme unzip the contents and try to install in this case mine was http://www....blah blah//1846/1864/install/install.php

 

Im greated with this error FATAL ERROR: register_globals is disabled in php.ini,

 

I have installed the patch, Overwriting the files, also tried creating my own php.ini file and uploading it to all the places that require it, and still no luck.

 

Any idea's what the problem could be??

 

Thanks

try using globals work around mod http://addons.oscommerce.com/info/5729 it seems you host has not allowed you to override settings

Link to comment
Share on other sites

They emailed me back syaing it was turned on

 

giving me this link http://supreme-webhosting.co.uk/phpinfo.php

 

now i cant see where it is enabled

 

 

 

when i click here to isntall the template

 

http://www.supreme-webhosting.co.uk/1864/install/install.php

 

 

I get FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

 

I dont know what else i can do

 

The host says its on and it isnt :S

Link to comment
Share on other sites

I found the .htaccess and added that line and still getting the same error :(

 

 

I was really hoping i could get this working.

Link to comment
Share on other sites

Tried the work around again, and still get the same error

 

 

I really, really want it working :(

ok paste the code of the that line here from the file that is giving you the error +5 lines below that to, we will just simply remove the check that stops the php script. if its turned on we wont have any problems, from that link host gave you http://supreme-webhosting.co.uk/phpinfo.php register globals is on

register_globals On On

Link to comment
Share on other sites

ok paste the code of the that line here from the file that is giving you the error +5 lines below that to, we will just simply remove the check that stops the php script. if its turned on we wont have any problems, from that link host gave you http://supreme-webhosting.co.uk/phpinfo.php register globals is on

register_globals On On

 

 

 

I don't know which you file you mean.

 

 

Im trying to upload a template so this is the install.php

 

 

?php

/*

$Id: install.php,v 1.3 2003/07/09 01:11:04 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application.php');

 

$page_file = 'install.php';

$page_title = 'Installation';

 

switch ($HTTP_GET_VARS['step']) {

case '2':

if (osc_in_array('database', $HTTP_POST_VARS['install'])) {

$page_contents = 'install_2.php';

} elseif (osc_in_array('configure', $HTTP_POST_VARS['install'])) {

$page_contents = 'install_4.php';

} else {

$page_contents = 'install.php';

}

break;

case '3':

if (osc_in_array('database', $HTTP_POST_VARS['install'])) {

$page_contents = 'install_3.php';

} else {

$page_contents = 'install.php';

}

break;

case '4':

if (osc_in_array('configure', $HTTP_POST_VARS['install'])) {

$page_contents = 'install_4.php';

} else {

$page_contents = 'install.php';

}

break;

case '5':

if (osc_in_array('configure', $HTTP_POST_VARS['install'])) {

if (isset($HTTP_POST_VARS['ENABLE_SSL']) && ($HTTP_POST_VARS['ENABLE_SSL'] == 'true')) {

$page_contents = 'install_5.php';

} else {

$page_contents = 'install_6.php';

}

} else {

$page_contents = 'install.php';

}

break;

case '6':

if (osc_in_array('configure', $HTTP_POST_VARS['install'])) {

$page_contents = 'install_6.php';

} else {

$page_contents = 'install.php';

}

break;

case '7':

if (osc_in_array('configure', $HTTP_POST_VARS['install'])) {

$page_contents = 'install_7.php';

} else {

$page_contents = 'install.php';

}

break;

default:

$page_contents = 'install.php';

}

 

require('templates/main_page.php');

?>

Link to comment
Share on other sites

Also here is .acsess as im still unware of which file you mean.

 

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

# SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive ssl-unclean-shutdown \

# downgrade-1.0 force-response-1.0

# </IfDefine>

#</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

# php_value session.use_trans_sid 0

# php_value register_globals 1

#php_flag register_globals on

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...