Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

desperate help needed getting email working through site


AR_1986

Recommended Posts

Hi, im trying to get email working from my site, having put the email address i wanted in E-mail Address and E-Mail From nothing happens. I try sending test emails from the contact us and i get nothing. what exactly is the E-Mail From line asking for? its default value is set to osCommerce <root@localhost> what do need to replace that with? I have already changed the value of E-mail address to [email protected] and i even tried pasting the same into the E-mail Address From line but nothing happens. Do i need to use my incoming and outgoing mail server on any of these or is an email address sufficent? Im confused lol thanks for you help people?

 

I know smtp is enabled because i use it for my outlook account. I have checked to see what my smtp settings are and have managed to get the following: -

 

SMTP server: authsmtp.streamline.net

SMTP username: your email address (ie [email protected])

SMTP password: your password

SMTP port: 25

 

but i still dont receive any emails when i send from my site.

 

i have the following settins on the Oscommerce admin: -

 

My Store

 

E-Mail Address- [email protected]

E-Mail From - [email protected]

 

E-Mail Options

 

E-Mail Transport Method - smtp

E-Mail Linefeeds - LF

Use MIME HTML When Sending Emails - true

Verify E-Mail Addresses Through DNS - true

Send E-Mails - true

 

My webhost server is set to Linux. If thats anhelp

Link to comment
Share on other sites

have you tried the sendmail or php mail() option?

Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Link to comment
Share on other sites

E-Mail Options

 

E-Mail Transport Method - sendmail

E-Mail Linefeeds - LF

Use MIME HTML When Sending Emails - false <--set to false for now

Verify E-Mail Addresses Through DNS - false

Send E-Mails - true

Link to comment
Share on other sites

E-Mail Options

 

E-Mail Transport Method - sendmail

E-Mail Linefeeds - LF

Use MIME HTML When Sending Emails - false <--set to false for now

Verify E-Mail Addresses Through DNS - false

Send E-Mails - true

 

Hi Bryce, i set everything as you said, but as soon as i click submit on the cointact us form it says 'Your enquiry has been successfully sent to the Store Owner' but having checked the email account i told it to go to = [email protected] it isnt there. any ideas? cheers mate.

Link to comment
Share on other sites

contact the hosting provider as the issue in the settings of the server.

Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Link to comment
Share on other sites

contact the hosting provider as the issue in the settings of the server.

 

I contacted them (streamline.net) and they were so unhelpful. Anyone else ever had this problem/overcome it? im at a complete standstill untill i figure this one out. :)

Link to comment
Share on other sites

unzip them

 

copy the file email_test to your catalog directory

 

go to your explorer and type http://www.yourwebname/catalog/email_test

 

Hi, thanks for your reply. I did as you said and i ran test email. When i try the following on the test_email form nothing happens, i check my outlook account and i haven't recieved anything:-

 

E-Mail From: [email protected]

E-Mail From Address: [email protected]

 

E-Mail To: [email protected]

E-Mail To Address: [email protected]

 

but if i try the following, it works: -

 

E-Mail From: [email protected]

E-Mail From Address: [email protected]

 

E-Mail To: [email protected]

E-Mail To Address: [email protected]

 

in fact i get 2 emails at a time delivered to my hotmail account, one of them goes straight to my inbox and i can see it says from [email protected] and its message reads 'This email has been sent from the email class osCommerce uses.'

 

The other email goes straight to my junk mail folder but says its from [email protected] and its message reads 'This email has been sent from the native php mail() function

 

Is this normal? should there be two emails?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...