Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help Installing Easy Populate


aj23

Recommended Posts

Well I finally got my site working again (thanks guys!!), and now need some help adding easypopulate. I tried to install it before, but it didn't work (easy populate showed up under my catalog admin page, but it took me to an error). I still have the files where I put them before, but I have no idea what I did, because after reading the instructions now, I don't even have most of the folders.

 

Here are the instructions,

 

* Copy folder ezpopulate into /catalog/admin/includes/applications/ or whatever folder you have placed the osCommerce admin.

* Copy file /catalog/admin/includes/applications/ezpopulate/access_ezpopulate.php into /catalog/admin/includes/modules/access folder.

* Rename /catalog/admin/includes/modules/access/access_ezpopulate.php to /catalog/admin/includes/modules/access/ezpopulate.php.

* Copy file /catalog/admin/includes/applications/ezpopulate/en_US_ezpopulate.php into /catalog/admin/includes/languages/en_US/modules/access folder.

* Rename /catalog/admin/includes/languages/en_US/modules/access/en_US_ezpopulate.php to /catalog/admin/includes/languages/en_US/modules/access/ezpopulate.php.

 

How can I follow them, if I do not have the folder they want me to put it into? Is there some where else these files should be going?

 

Thanks

Link to comment
Share on other sites

If you don't have those folders, it may be a good idea to create them and put the files there. What goes to the languages/en_US folder, most of the installations only have a languages/english directory, so this might work but I'm not too familiar with EP, so give it a try.

Link to comment
Share on other sites

If you don't have those folders, it may be a good idea to create them and put the files there. What goes to the languages/en_US folder, most of the installations only have a languages/english directory, so this might work but I'm not too familiar with EP, so give it a try.

 

Alright I'll try that and hopefully it works. I was just thinking that maybe there was another folder for them to be in, but I guess not.

Link to comment
Share on other sites

Alright I'll try that and hopefully it works. I was just thinking that maybe there was another folder for them to be in, but I guess not.

 

You know what, I think it was because I'm using the wrong version of easy populate. Which one should I use on v2.2?

Link to comment
Share on other sites

You know what, I think it was because I'm using the wrong version of easy populate. Which one should I use on v2.2?

 

 

 

I use EP_V2_76e, and have no trouble whatsoever.

Link to comment
Share on other sites

You don't have the standard rc2a directory structure, so willneed to work out whhere everything should go and maybe change the code to reflect the structure.

 

Good luck

 

G

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

You don't have the standard rc2a directory structure, so willneed to work out whhere everything should go and maybe change the code to reflect the structure.

 

Good luck

 

G

 

I re-installed the correct version (well I think I did have the correct version before anyways, but I had both folders on my desktop).

 

Anyways, it still doesn't work, does anyone know the problem?

 

here is the error,

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Link to comment
Share on other sites

I am having trouble finding the EZPopulate package compatible with Version 2.2, (I can see EZPopulate for the Alpha 3.0 version). I would really appreciate it if someone could please point me to it?

Link to comment
Share on other sites

Easy Populate v2

Eazy Populate v3

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

I am having trouble finding the EZPopulate package compatible with Version 2.2, (I can see EZPopulate for the Alpha 3.0 version). I would really appreciate it if someone could please point me to it?

 

Thank you Geoffrey! I am new here, so I am still a bit lost. Thanks for taking the time to reply!

Link to comment
Share on other sites

I am having trouble finding the EZPopulate package compatible with Version 2.2, (I can see EZPopulate for the Alpha 3.0 version). I would really appreciate it if someone could please point me to it?

 

Thank you Geoffrey! I am new here, so I am still a bit lost. Thanks for taking the time to reply!

Link to comment
Share on other sites

Thank you for both sets of thanks

 

:-)

 

How did you manage to do that? I can only sent one post every 5 minutes

 

BTW the usefull threads link below might be of help

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

Does anyone know why I might be receiving my problem, causing this not to work? I only have about 50 products ready to add now, but I want to test it out, and it would still take forever for manual additions.

Link to comment
Share on other sites

What version of osc do you have installed?

 

What contribution did you install?

 

What are the permissions of each file you have uploaded?

 

Have you read the installation instructions?

 

If installing Easy Populate did you followed the section on asking for help?

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

What version of osc do you have installed?

 

What contribution did you install?

 

What are the permissions of each file you have uploaded?

 

Have you read the installation instructions?

 

If installing Easy Populate did you followed the section on asking for help?

 

Ok I fixed my problem, but I cannot seem to get to edit the complete file and add products. How do I go about doing this?

 

Thanks

 

And by looking at the list, I don't see how this would be much faster, even for a lot of products, since it gets a little confusing, and I have no idea how I would upload an image. Plus I'd need to type out everything (manufacturer, etc) instead of just choosing it from a list.

 

I still want to try it and see how it is though, since many others like to use the contribution.

Link to comment
Share on other sites

Ok I fixed my problem, but I cannot seem to get to edit the complete file and add products. How do I go about doing this?

 

Thanks

 

And by looking at the list, I don't see how this would be much faster, even for a lot of products, since it gets a little confusing, and I have no idea how I would upload an image. Plus I'd need to type out everything (manufacturer, etc) instead of just choosing it from a list.

 

I still want to try it and see how it is though, since many others like to use the contribution.

 

Anyone? Sorry for bumping a lot, but I know this thread will go unanswered on the second page.

Link to comment
Share on other sites

Ok I fixed my problem, but I cannot seem to get to edit the complete file and add products. How do I go about doing this?

 

Thanks

 

And by looking at the list, I don't see how this would be much faster, even for a lot of products, since it gets a little confusing, and I have no idea how I would upload an image. Plus I'd need to type out everything (manufacturer, etc) instead of just choosing it from a list.

 

I still want to try it and see how it is though, since many others like to use the contribution.

 

Help please.

 

Thanks in advance.

Link to comment
Share on other sites

I ended up getting excel and it works now, but can anyone tell me why it isn't working? I tried one product as a test and it didn't go onto the site. BTW, how do I put images into easypopulate way of adding products?

 

Here is the error.

Warning: move_uploaded_file(/home/aj23/public_html/temp/EZ Populate Test.csv) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/aj23/public_html/admin/easypopulate_functions.php on line 44

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpNkXd4B' to '/home/aj23/public_html/temp/EZ Populate Test.csv' in /home/aj23/public_html/admin/easypopulate_functions.php on line 44

File uploaded.
Temporary filename: /tmp/phpNkXd4B
User filename: EZ Populate Test.csv
Size: 197426

Warning: file(/home/aj23/public_html/temp/EZ Populate Test.csv) [function.file]: failed to open stream: No such file or directory in /home/aj23/public_html/admin/easypopulate.php on line 1076

Warning: fopen(/home/aj23/public_html/temp/EZ Populate Test.csv) [function.fopen]: failed to open stream: No such file or directory in /home/aj23/public_html/admin/easypopulate.php on line 1101
##Can not open file for reading. Script will terminate.

 

Anyone know the problem?

Link to comment
Share on other sites

I ended up getting excel and it works now, but can anyone tell me why it isn't working? I tried one product as a test and it didn't go onto the site. BTW, how do I put images into easypopulate way of adding products?

 

Here is the error.

Warning: move_uploaded_file(/home/aj23/public_html/temp/EZ Populate Test.csv) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/aj23/public_html/admin/easypopulate_functions.php on line 44

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpNkXd4B' to '/home/aj23/public_html/temp/EZ Populate Test.csv' in /home/aj23/public_html/admin/easypopulate_functions.php on line 44

File uploaded.
Temporary filename: /tmp/phpNkXd4B
User filename: EZ Populate Test.csv
Size: 197426

Warning: file(/home/aj23/public_html/temp/EZ Populate Test.csv) [function.file]: failed to open stream: No such file or directory in /home/aj23/public_html/admin/easypopulate.php on line 1076

Warning: fopen(/home/aj23/public_html/temp/EZ Populate Test.csv) [function.fopen]: failed to open stream: No such file or directory in /home/aj23/public_html/admin/easypopulate.php on line 1101
##Can not open file for reading. Script will terminate.

 

Anyone know the problem?

 

UP

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...