Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Help with php.ini


Recommended Posts

Hi all...


accidentally screwed up my site which has led to a long road of changing providers, hosting etc. I am finally getting back on track but when trying to connect my site to the OScommerce site I am getting the following error:


FATAL ERROR: register_globals is disabled in php.ini, please enable it!


Here is the text from my php.ini file:


register_globals = on

allow_url_fopen = off


expose_php = Off

max_input_time = 60

variables_order = "EGPCS"

extension_dir = ./

upload_tmp_dir = /tmp

precision = 12

SMTP = relay-hosting.secureserver.net

url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="






Any clue what might be wrong?



Link to comment
Share on other sites

Tried this to no avail...


Register Globals is off and cannot be turned on. chillininvt 26 Jul 2007


If you add the following link to your .htaccess file oscommerce will work fine. My .htaccess file consists of one line this.


php_flag register_globals on



put that in your .htaccess file and you will be able to run os commerce with register globals off in your php.ini




Thanks Joe...


Unfortunately I am OScommerce "dumb" enough to not be able to put that to much use. Can you put it in dummy proof terms?



Link to comment
Share on other sites

It depends on how your server is configured. Some have PHP settings (such as register globals) in .htaccess, while others require that they be put in php.ini. Then, some servers require an entry in .htaccess to tell PHP where to find php.ini. Talk to your hosting service to see what needs to be done on any particular server.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...