Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Protx Form - Not saving orders or redirecting


meshdesign

Recommended Posts

Hi all, trying to get to grips with the latest protx form contribution. (couldnt find a proper forum thread, please give me a link if there is one)

 

1. i am in the testing phase and i have got it into a position where the order goes through and myself and the customer receives a confirmation email from SAGEPAY.

2. However when i click the proceed button on sagepay it does not re-direct me to the confirmation page - just back to the start of the checkout procedure with the items still in my basket.

3. orders are not saved to the database

4. transactions are not shown in my sagepay (but i'm 99% sure this is a sagepay issue)

 

I am not PREAUTH enabled, and am unsure whether that is a reason behind it.

 

If anybody could advise me it would be the most appreciative i've been for a long long time :D as i have customers breathing down my neck wondering why they can't order anything yet,

 

Kind Regards

Daniel Hodkinson

Link to comment
Share on other sites

  • 1 month later...

Hi,

did you find a solution for this?

 

I have the exact same problem on my live site. My test site works perfectly and I am confused. I don't know if the payment show on the sage account as I'm waiting for them to activate my account to "Test Mode".

 

 

After payment you get redirected to https://www.mysite.co.uk/checkout_payment.php?error_message=

 

 

Just got my merchant number so a little sad this has occured when I thought all was ok and I was fairly ready to go live :(

 

Tigergirl

Edited by tigergirl

I'm feeling lucky today......maybe someone will answer my post!

I do try and answer a simple post when I can just to give something back.

------------------------------------------------

PM me? - I'm not for hire

Link to comment
Share on other sites

Forgot to say it's Protx/ Sage Pay Form 1-20-1 I'm using on 060817.

 

Live & Test sites hosted on same server and should be pretty similar except the content.

The debug came back with:

 

2.22

PAYMENT

TestVendor

VendorTxCode=TestVendor200907091510445&Amount=8.29&Currency=GBP&Description=Goods bought from mystore&SuccessURL=https://www.mystore/checkout_process.php&FailureURL=https://www.mystore/checkout_process.php&CustomerName=Test Customer&CustomerEmail=myemail@myemailuk&VendorEMail=myemail@myemailuk&DeliveryAddress=Test address&DeliveryPostCode=test postcode&BillingAddress=Test address&BillingPostCode=test postcode&Basket=3:Soap:1:0.89:0.00:0.89:0.89:Pads:1:4.99:0.00:4.99:4.99:Shipping:1:2.

41:----:2.41:2.41

 

There must be something going on - could it be a file difference or a sessions problem? I'm not aware of losing sessions. If it's a file, can anyone give me a some starting points for where to look so I can compare the files??? What files would be called after you are returned to the website form SagePay?

 

I tried this thread protx form not redirecting but the crypt thing doesn't make a difference.

 

Many thanks

Tigergirl

I'm feeling lucky today......maybe someone will answer my post!

I do try and answer a simple post when I can just to give something back.

------------------------------------------------

PM me? - I'm not for hire

Link to comment
Share on other sites

well,

now my sagepay vendor account is active, I do not have this problem. No idea why using the testvendor details causes the error.

 

BTW version 1-20-1 isn't the most up to date version and although it says it has stripped out any reference to protx, protx is still there... and I think it's using the old protocol so you'll need to pick the module that works with the new billing fields for 3d secure.

 

Cheers

I'm feeling lucky today......maybe someone will answer my post!

I do try and answer a simple post when I can just to give something back.

------------------------------------------------

PM me? - I'm not for hire

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...