Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sitemap SEO


Jack_mcs
 Share

Recommended Posts

  • 2 months later...

becose some codes are diferent in index & product_info.

Most must be able 2 integrate, but would that not inteferrer/damaged the other one?

I just tried but got an error in catalog/index :

1146 - Table 'hellcars_BS4B.TABLE_HEADERTAGS_DEFAULT' doesn't exist
 
select * from TABLE_HEADERTAGS_DEFAULT where language_id = '1'
 
& in adminsite above the categories there was box-header-blablabla. the Header Seo funciones.
 
I took copy of this shop & replaced with my working one to go further.
So I have all the files on my pc & onlline
 
I think is only index & product_info that cause problemos
 
saludos
Edited by SpicyGirl
Link to comment
Share on other sites

When you see an error with capital letters, like TABLE_HEADERTAGS_DEFAULT, it means you are missing a definition. That particular one is for Header Tags SEO but isn't added by this addon. It appears you've made a mistake in the installation of Header Tags SEO. See the instruction in that package for changes to be made to the database_tables.php file.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

  • 2 months later...

Hi!

 

Thank you for your contributions!

 

I've just installed sitemap SEO, and I'm having this error:

 

"

Warning: require(includes/classes/category_tree_standard_no_products.php) [function.require]: failed to open stream: No such file or directory in /(....)/public/shop/sitemap.php on line 63

Fatal error: require() [function.require]: Failed opening required 'includes/classes/category_tree_standard_no_products.php' (include_path='.') in /(....)/public/shop/sitemap.php on line 63

"

 

I've checked the directory and the file is there.

 

Also, in the page itself, in the information box i get this:

 

"MODULE_BOXES_INFORMATION_SITEMAP_SEO"

 

Can you help?

 

Thank you.

 

Best regards,

 

Joao

Edited by alvesjc
Link to comment
Share on other sites

@@alvesjc The first error is because there is a missing file. My guess is that you didn't upload the new files. Please be sure you have followed the instructions in step 2. If you are still having problems, please state what version of oscommerce you are using.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Hi Jack.

Thank you for your reply.

 

I've upload all the " catalog_Only_New_Files ".

 

In fact you're right, the file is missing. But it's missing from your folder also.

 

I only see this one:

category_tree_no_products.php

 

Is this just a bad file name call, or is really missing this file?

 

thank you.

Link to comment
Share on other sites

That's the name of the file in the error you posted. If you are seeing some other name please let me know what it is so I can check it.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

The error: require(includes/classes/category_tree_standard_no_products.php)

 

complains about:

 

category_tree_standard_no_products.php

 

but I only have available in the zip this one:

 

category_tree_no_products.php

 

I don't have any file with the "standard" word in the middle.

 

Can you help?

 

PS:

 

just found the file inside "After_2.3_BS_ONLY" folder.

 

I've used the folder "After_2.3"

 

By the way, my OSC is 2.3.3

Edited by alvesjc
Link to comment
Share on other sites

I've uploaded the contents of "After_2.3_BS_ONLY" and now works, only one thing missing I think,

 

How do I rename the link for the sitemap in the information box? It's showing:

 

MODULE_BOXES_INFORMATION_SITEMAP_SEO

Link to comment
Share on other sites

Ok, just fixed it adding:

 

define('MODULE_BOXES_INFORMATION_SITEMAP_SEO', 'Sitemap');

 

to the bm_information.php in

 

/catalog/includes/languages/english/modules/boxes

 

Thank you for your help!

 

Regards.

Link to comment
Share on other sites

@@alvesjc I assumed you were using the Bootstrap version. Please always mention your version in any thread you post on these forums to avoid confusion.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Dear Jack

 

I just install your contribution and I get the following error:
 
1146 - Table 'oscnt235.sitemap_seo_settings' doesn't exist

select * from sitemap_seo_settings where language_id = '2' LIMIT 1

[TEP STOP]
 
What could be happening?
 
Best regards
 
Valqui

:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Link to comment
Share on other sites

Dear @@Jack_mcs

 

In the Admin i get the following error:

 

1146 - Table 'oscnt235.sitemap_seo_boxes' doesn't exist

select count(*) as total from sitemap_seo_boxes where box_file_name LIKE 'bm_best_sellers.php' and language_id = '2'

[TEP STOP]

 

What could be happening?
 
Best regards
 
Valqui

:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Link to comment
Share on other sites

Dear @Jack_mcs
 
Yes, I did it and not recive any problems.
 
recently I  run the sitemap_seo_install.php file again and received the following error:
 
Warning: mysqli_num_rows() expects parameter 1 to be mysqli_result, array given in /home/......./html/235/catalog/includes/functions/database.php on line 104
Sitemap SEOSitemap SEO Database installer
Database successfully updated for Sitemap SEO!!!

 

any clues?

 

Best regards.

 

Valqui

:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Link to comment
Share on other sites

You shouldn't run it twice. Try running it this way to try to clear that:

http:// YOUR DOMAIN NAME /sitemap_seo_install.php?reset

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Jack, I have another problem :

 

in the admin - Box Control

 

I get the following error when I Select a Box :

 

Warning: file(/home/content/n/..................../catalog/includes/modules/boxes/Array) [function.file]: failed to open stream: There is no file or directory in /home/content/n/e/w/newtekuy/html/235/catalog/admin/includes/functions/sitemap.php on line 203

 

Best Regards

 

Valqui

:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...