Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Extra Product Fields


Recommended Posts

Hi all,


I am having issues installing the "extra product fields" contribution, and would really appreciate some advice from anyone who has installed it and has it working with v2.2 RC2a. Yes, I have searched the forum for information, and all I seem to find is fragmented, irrelevant or incomplete information about issues related to the one I am having, none of which have been any help to me.


What I need to know is simply this:


1. When starting with a clean install of RC2a, which particular download of "extra product fields" do I need to install (date and contributors name please)?


2. Furthermore, which other "extra product fields" downloads (again, dates and names please) do I then need to obtain and use in order to make my store secure and fully functional?


If anyone can provide a definitive answer to this question, I am sure it will help others, and not just me (there seem to be several posters confused with this particular contribution around here); although, having said that, I would truly be most grateful myself for any guidance that helps me get this working.


Many thanks in advance for any help that is offered....,


Link to comment
Share on other sites

All you have to do is read the descriptions of each of the packages for the contribution apply the latest full package and any fixes posted afterwards.


My reading of it is wdepot + fixes.


Worked fine for me with a little jiggery pokery on the product info page and Easy Populate.

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile


Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.


For links mentioned in old answers that are no longer here follow this link Useful Threads.


If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

Thanks for your reply Geoffrey; I have agreed with your opinion on the version I should be trying install since looking at the contribution page for the first time. In fact I installed that very version (wdepot 13-06-2008) twice, but couldn't make it work (I figured I had nerfed the install).


The breakthrough for me was stumbling accross the information in this forum today about the Apple Macintosh formatted file (admin/product_extra_field.php) in that particular full release. It is only since I have used Notedpad++ to convert the file to Windows format that I have managed to get this contribution working.


I do have another problem now though :).........


I have applied all the fixes released since wdepot's full release (apart from the Dutch translation), but when I use the stores search function I get the following error:


1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') left join manufacturers m using(manufacturers_id) left join specials s on p.pr' at line 1


select count(distinct p.products_id) as total from products p left join products_to_products_extra_fields p2pef on p.products_id=p2pef.products_id) left join manufacturers m using(manufacturers_id) left join specials s on p.products_id = s.products_id, products_description pd, categories c, products_to_categories p2c where p.products_status = '1' and p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and ((pd.products_name like '%asd%' or p.products_model like '%asd%' or m.manufacturers_name like '%asd%' or p2pef.products_extra_fields_value like '%asd%') )




Any ideas Geoffrey, or anyone else?




Edited by Cyburg
Link to comment
Share on other sites

Ok, so in instructions for installing version 2.0j of Product Extra Fields by wdepot (13-16-2008), the code in the section about modifying "advanced_search_results.php" did not match the code in my osc install file (I think this had something to do with the tax settings on my store?).


Anyway, when I copy/pasted the extra required piece of sql from the 2.0j install text file, I accidentally copied a closing brace (or at least I think I did), after deleting it my problem is now solved.


For anyone else wondering why the piece of code in the 2.0j instructions for the "advanced_search_results.php" file looks different to the one in their install file, I have found the code below works for me (I have commented out the original line of code):



$from_str = "from " . TABLE_PRODUCTS . " p left join " . TABLE_PRODUCTS_TO_PRODUCTS_EXTRA_FIELDS . " p2pef on p.products_id=p2pef.products_id) left join " . TABLE_MANUFACTURERS . " m using(manufacturers_id) left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id";

// $from_str = "from " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m using(manufacturers_id) left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id";


if ( (DISPLAY_PRICE_WITH_TAX == 'true') && (tep_not_null($pfrom) || tep_not_null($pto)) ) {

if (!tep_session_is_registered('customer_country_id')) {

$customer_country_id = STORE_COUNTRY;

$customer_zone_id = STORE_ZONE;


$from_str .= " left join " . TABLE_TAX_RATES . " tr on p.products_tax_class_id = tr.tax_class_id left join " . TABLE_ZONES_TO_GEO_ZONES . " gz on tr.tax_zone_id = gz.geo_zone_id and (gz.zone_country_id is null or gz.zone_country_id = '0' or gz.zone_country_id = '" . (int)$customer_country_id . "') and (gz.zone_id is null or gz.zone_id = '0' or gz.zone_id = '" . (int)$customer_zone_id . "')";







Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...