Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

New Install - Two errors


Recommended Posts

I just installed the Shopping cart and When I launch the store I get this error: Warning: I am able to write to the configuration file: /home/by/public/viv/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.


I have CHMODed the file to 644 but it still gives me this error, why and how do I fix this?



When I launch the admin panel I get this error: FATAL ERROR: register_globals is disabled in php.ini, please enable it!


Not sure why as I have the php.ini in root and th store works fine except for the write error issue on the top of the page.


Thank you for your help.



Link to comment
Share on other sites

Ok, will do. I did try 444 and same error. it is really weird.



The site is a template site I got so it has a template with it. Is it easy to upgrade after I install this version or is there a way to install the new version and then just plugin the template I have with this all in one package?



Link to comment
Share on other sites

It isn't a simple process to update to the latest version - RC2a. You have to go through a process of all the 2.2 updates to 060817, then the update to RC1 and finally RC2.

All the updates are included within the latest package - a text file to update 060817 and a Diff page for the RC1/RC2 changes - but you need a spare afternoon to go through it.

The problem with a template is some pull the code around a bit. So, some of the changes might not be as obvious - maybe!


Some hosts setup their servers so you can't change permission levels via FTP. Go to your hosting control panel and try to change permissions to 444 from there. If that still doesn't work, ask your host to do it for you.

Link to comment
Share on other sites

Ok thanks I will go through the documents and see when I have time to do the update.


I can get to the store now but get this error for the admin panel:


Fatal error: Cannot re-assign $this in /home/by/public_html/viv/Store/admin/includes/classes/upload.php on line 31



Link to comment
Share on other sites

Yeah I have osCommerce 2.2-MS2



Also get this error for the FAQ's


Warning: require(includes/languages/english/FILENAME_FAQS) [function.require]: failed to open stream: No such file or directory in /home/by/public_html/viv/Store/faqs.php on line 15


Fatal error: require() [function.require]: Failed opening required 'includes/languages/english/FILENAME_FAQS' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/by/public_html/viv/Store/faqs.php on line 15



Line 15 is:


require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_FAQS);

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...