Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Unable to determine connection method


sturla69

Recommended Posts

Hi.

 

I run a heavily modified osCommerce site, and this has "suddenly" started to generate the following error message on the page create_account_success.php:

------------------------

 

Error!

 

Unable to determine connection method on a link!

 

Known methods: NONSSL SSL

 

------------------------

 

This error only occurs when a customer tries to register, AFTER putting something in the shopping cart. When the cart is empty, registering is problem free. The customer is registered and active after submitting, so the system writes the info to the database and logs them in. Therefore I suspect that there is something wrong in a redirect or something on the before mentioned page. Since it fails on create_account_success.php, the error must be there somewhere. This is the code for the page:

 

	<?php
/*
  $Id: create_account_success.php,v 1.30 2003/06/05 23:27:00 hpdl Exp $

  osCommerce, Open Source E-Commerce Solutions
  [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

  Copyright © 2003 osCommerce

  Released under the GNU General Public License
*/

  require('includes/application_top.php');

  require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CREATE_ACCOUNT_SUCCESS);

  $breadcrumb->add(NAVBAR_TITLE_1);
  $breadcrumb->add(NAVBAR_TITLE_2);

  if (sizeof($navigation->snapshot) > 0) {
    $origin_href = tep_href_link($navigation->snapshot['page'], tep_array_to_string($navigation->snapshot['get'], array(tep_session_name())), $navigation->snapshot['mode']);
    $navigation->clear_snapshot();
  } else {
    $origin_href = tep_href_link(FILENAME_DEFAULT);
  }
?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>
<!-- Mulig feilkilde iflg Sturla -->
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<link rel="stylesheet" type="text/css" href="sty_fmb.css">
</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
<div id="pgLyr">
<!-- Begin: Page Layer-->

<!-- header //-->
<?php require(DIR_WS_INCLUDES . 'header.php'); ?>
<!-- header_eof //-->

<div id="bdyLyr">
<!-- Begin: Body Layer -->
	<div id="lftLyr">
<!-- Begin: Left Layer -->
		<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>
<!-- End: Left Layer -->
	</div>
	<div id="cntLyr">
<!-- Begin: Content Layer -->



<?php echo start_mainbox(10,460,true);?>
 <h3 class="cWh"><?php echo HEADING_TITLE; ?></h3></div>	<div class="bxBdBg">
     		<div><?php echo TEXT_ACCOUNT_CREATED; ?></div>
		<div><?php echo '<a href="' . $origin_href . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></div>

	   <?php echo end_mainbox();?>
<!-- body_text_eof //-->

<!-- End: Content Layer -->
	</div>

	<div id="rgtLyr">
	<!-- Begin: Right Layer -->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
	<!-- End: Right Layer -->
		</div>



<!-- End: Body Layer -->
	</div>


<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>


<!-- End: Page Layer -->
</div><br />
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

Could someone please look at this and adivse me on how to resolv the error?

Site can be found here: www.familiebutikken.no

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...